Bug 1341551 - bad filters for MON host in bad state
Summary: bad filters for MON host in bad state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-01 09:38 UTC by Lubos Trilety
Modified: 2016-08-23 19:53 UTC (History)
4 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:53:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
filtered hosts (42.40 KB, image/png)
2016-06-01 09:38 UTC, Lubos Trilety
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-06-01 09:38:27 UTC
Created attachment 1163560 [details]
filtered hosts

Description of problem:
If there is some bad (war/error) event for host it is counted correctly on dashboard, but when it's clicked on the event number it filters wrongly the hosts list. It looks only for hosts with OSD role, such filter should not be there at all.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.21-1.el7scon.x86_64
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create some cluster
2. Stop some monitor in the cluster, wait till the event is created
3. Open some dashboard and click on event number in the Hosts section

Actual results:
No host is displayed in the list as the problem is not on host with OSD role.

Expected results:
The filter for OSD role should not be there.

Additional info:

Comment 2 Sharmilla Abhilash 2016-07-07 04:29:41 UTC
setting up the bug priority as per PM priority.

Comment 4 Lubos Trilety 2016-07-21 11:54:28 UTC
Tested on:
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch

No OSD filter present.

Comment 6 errata-xmlrpc 2016-08-23 19:53:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.