Bug 1341686 - ceph-installer prints output to console during installation
Summary: ceph-installer prints output to console during installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-06-01 13:48 UTC by Ken Dreyer (Red Hat)
Modified: 2016-08-23 19:53 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-installer-1.0.12-2.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:53:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Ken Dreyer (Red Hat) 2016-06-01 13:48:03 UTC
Description of problem:
"yum install ceph-installer" prints messages to the console.

Version-Release number of selected component (if applicable):
ceph-installer-1.0.11-1.el7scon

How reproducible:
always

Steps to Reproduce:
1. Start with a RHEL 7 system
2. Enable the yum repository that contains the ceph-installer package
3. yum install ceph-installer

Actual results:
The RPM prints the following messages to the console:

   ==> LOADING ENVIRONMENT
   ==> BUILDING SCHEMA
   ==> STARTING A TRANSACTION...
   ==> COMMITING...


Expected results:
The RPM installation is silent

Additional info:
This is a result of not piping the "pecan populate" command in %post to /dev/null.

Comment 2 Ken Dreyer (Red Hat) 2016-06-01 13:49:54 UTC
PR upstream at https://github.com/ceph/ceph-installer/pull/160

Comment 3 Ken Dreyer (Red Hat) 2016-06-01 15:40:51 UTC
PR is merged upstream. Need to make the equivalent change in the downstream ceph-installer.spec.

Comment 8 Rachana Patel 2016-07-28 21:01:46 UTC
Verified with - ceph-installer.noarch 0:1.0.14-1.el7scon

Comment 10 errata-xmlrpc 2016-08-23 19:53:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.