Bug 1341699 - over-broad dependency on parted package
Summary: over-broad dependency on parted package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Ali Maredia
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-06-01 14:24 UTC by Ken Dreyer (Red Hat)
Modified: 2016-08-23 19:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:40:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Ken Dreyer (Red Hat) 2016-06-01 14:24:06 UTC
Description of problem:
ceph-base requires the parted package. This means that any installation of ceph-osd, ceph-mon, or ceph-mds will pull in the parted package.

We should move the parted dependency to the ceph-osd subpackage, since ceph-disk is the only thing that uses parted.

The advantage of this change is that Mon and MDS systems will not need to install the parted package, and we will not need to ship the new parted package in our Mon and Tools repositories.

Version-Release number of selected component (if applicable):
ceph-10.2.1-12.el7cp

How reproducible:
always

Steps to Reproduce:
1. Start with a RHEL 7 system
2. Ensure that the parted package is not present on your system.
3. "yum install ceph-mon" or "yum install ceph-mds"


Actual results:
Yum installs parted.

Expected results:
Yum should not try to install parted.

Additional info:
This change was merged to master upstream in https://github.com/ceph/ceph/pull/9415

Comment 3 Rachana Patel 2016-07-06 18:29:58 UTC
verified with version - 
ceph version 10.2.2-9.el7cp (ece2b6d4849364cdca71fb66895409b0f34c199f)

working as expected hence moving to verified

Comment 5 errata-xmlrpc 2016-08-23 19:40:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.