Bug 134170 - Advanced features such as stapling & holepunch needed in libgnomeprintui
Advanced features such as stapling & holepunch needed in libgnomeprintui
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libgnomeprintui22 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 17:59 EDT by Anonymous
Modified: 2008-08-04 22:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 16:03:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anonymous 2004-09-29 17:59:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
This is simply an RFE for the gnome printing dialogue.  It seems to me
that this dialogue should support most, if not all, of the same
options that "lp" supports on the commandline.  Specifically, I'm
currently looking for the Stapling and HolePunch options.  They work
beautifully via "lp", so I don't imagine this is difficult to
implement.  Also, OpenOffice.org has a print dialogue which handles
these options.

Version-Release number of selected component (if applicable):
libgnomeprintui22-2.7.1-7

How reproducible:
Always

Steps to Reproduce:
not really applicable... this is an RFE, not a bug... but if you
really want...

1.  Launch a Gnome app such as Evolution
2.  Click the print icon

Actual Results:  Stapling and Hole Punch options are nowhere to be found.

Expected Results:  Stapling and Hole Punch options should be available
for individual print jobs.

Additional info:

As a side note, it would be really nice to see a standard print
dialogue across all GNOME apps, at a minimum.  If epiphany and
OpenOffice.org both used the standard dialogue, that would be a start;
of course, the OOo setup is currently more full-featured than this
one, hence this RFE.
Comment 1 Owen Taylor 2004-09-30 16:03:03 EDT
Filed upstream as:

 http://bugzilla.gnome.org/show_bug.cgi?id=154196

The plan is definitely to get openoffice and the browsers using
the libgnomeprint interface.
Comment 2 Jens Lautenbacher 2005-08-08 22:43:12 EDT
Filing upstream for gnome print stuff generally doesn't seem to work too good -
I think the whole area is rather underestimated. I even havn't been able to find
a active mailing list to discuss this stuff...

Is there any progress made somewhere when it comes to gnome-print and if yes,
where can it be tracked?

Note You need to log in before you can comment on or make changes to this bug.