Bug 1341730 - Rebase the binutils to release 2.25.1
Summary: Rebase the binutils to release 2.25.1
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils
Version: 7.3
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: ---
Assignee: Nick Clifton
QA Contact: Miloš Prchlík
Tomas Capek
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-01 15:42 UTC by Nick Clifton
Modified: 2016-11-04 01:55 UTC (History)
5 users (show)

(edit)
_binutils_ rebased to version 2.25.1

The highlights of the new rebased _binutils_ package include:

  * The *strings* program now has a "--data" command-line option which only prints strings in loadable, initialized data sections. The default behaviour has been changed to match the "--all" command-line option.  

  * The *strings* program now has a "--include-all-whitespace"  command-line option which treats any non-displaying ASCII character as part of the string. This includes carriage return and new line characters which otherwise would be considered to be line terminators.

  * The *objcopy* program now has a "--dump-section" command-line option to extract the contents of named sections and copy them into separate files.

  * The *objcopy* program now supports wildcard characters in command-line options that take section names.

  * The *as* assembler now has a "--gdwarf-sections" command-line option to enable the generation of per-code-section *DWARF.debug_line* sections. This facilitates the removal of those sections when their corresponding code section is removed by linker garbage collection.
Clone Of:
(edit)
Last Closed: 2016-11-04 01:55:53 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2265 normal SHIPPED_LIVE binutils bug fix update 2016-11-03 13:33:42 UTC

Description Nick Clifton 2016-06-01 15:42:36 UTC
Description of problem:

  The version of binutils currently used in RHEL 7.3 is 2.23.  This is quite
  an old version and in particular suffers from a lot of potential security
  problems due to buffer overruns and memory leaks.

Version-Release number of selected component (if applicable):

  2.23.52.0.1-56

How reproducible:

  Examine version number in the rpm.

Actual results:

  2.23

Expected results:

  2.25.1

Additional info:

  Rebasing to a newer version of binutils has the potential to cause new,
  unexpected failures in other packages.  But we have been doing a lot of
  local testing and nothing has shown up so far.

Comment 3 Miloš Prchlík 2016-06-27 13:19:41 UTC
Verified for build binutils-2.25.1-20.base.el7.

Comment 7 errata-xmlrpc 2016-11-04 01:55:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2265.html


Note You need to log in before you can comment on or make changes to this bug.