Bug 134176 - "Error showing url" when "Get more extensions" is clicked
"Error showing url" when "Get more extensions" is clicked
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
Blocks: 131589
  Show dependency treegraph
Reported: 2004-09-29 19:36 EDT by Ben Levenson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-05 16:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2004-09-29 19:36:46 EDT
Description of problem:
Clicking the "Get more extensions" link from Thunderbird produces
the following error:

  Error showing url: There was an error launching the
  default action command associated with this location.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Use "Preferred Applications" to set default mail client to 
Thunderbird, and default web browser to firefox.
2. Launch Thunderbird and go to Tools -> Extensions
3. Click "Get more extensions"
Actual results:
Error message described above.

Expected results:
Firefox should launch and go to the https://update.mozilla.org/ page
for Thunderbird extensions.

Additional info:
Same error message is produced when "Get more themes" is clicked.
Firefox is launched as expected when clicking links in an email 
Comment 1 Christopher Aillon 2004-10-05 16:12:50 EDT
Works fine for me in latest rawhide.
Comment 2 Giuseppe Castagna 2004-11-12 16:00:21 EST
I had the same problem. If it is like me it comes from an older
configuration I herited from first versions of Thunderbird. This can
be solved by changing the default browser twice. If you use GNOME2 you
can go to: GNOME Control Centre> Advanced> Preferred Applications and
configure your default browser (do it once with Mozilla, and the
second time wih Firefox) ... it should now work.

Comment 3 Andy Green 2005-01-22 05:05:17 EST
Thanks to Beppe for the hint above.  It is indeed caused by bringing
over a /home dir containing old info.

If you are not running Gnome, and only have KDE installed, you can fix
it like this:

vi ~/.gconf/desktop/gnome/url-handlers/http/%gconf.xml

(Do the same for https after :
vi ~/.gconf/desktop/gnome/url-handlers/https/%gconf.xml )

Change (well... this is what I saw) the bad
/usr/lib/firefox-0.10-1/firefox to /usr/bin/firefox  My current
firefox was 1.0, maybe I did not run Gnome since that time or something.

Save it.  Then one more step, gconfd runs as the interface to this
stuff for Firebird, even when you are KDE-only.  It has the old config
still loaded.  You must killall -9 gconfd-2, then Firebird will
properly service URL clicks.  Woohoo!
Comment 4 George Toft 2005-01-29 14:29:51 EST
I am running FC3 using icewm as my window manager.  No HTML links will
work in Thunderbird - not even the ones in the Welcome to Mozilla
Thunderbird panel.

The above files do not exist on my system
(~/.gconf/desktop/gnome/url-handlers/http/%gconf.xml, etc)

Here's what I did to get it working.
1.  Based on info here:
I located my prefs file ~/.thunderbird/60hya6x9.default/prefs.js -
your location will be different - just look under ~/.thunderbird

2.  Stop thunderbird - it seems to write the prefs.js file upon exit.

3.  I added the following line BEFORE the
user_pref("network.proxy.ftp"... entry:

4.  Saved file

5.  Start thunderbird.

Note You need to log in before you can comment on or make changes to this bug.