Bug 1341782 - Progress bar in View and Accept Hosts screen does not provide meaningful feedback
Summary: Progress bar in View and Accept Hosts screen does not provide meaningful feed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-01 18:34 UTC by Matt Carrano
Modified: 2016-08-23 19:53 UTC (History)
8 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:53:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
View and Accept Hosts-Initialization in progress (96.44 KB, image/png)
2016-06-01 18:34 UTC, Matt Carrano
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1313770 0 unspecified CLOSED "Initialize" task is not started for few hosts sometimes 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Internal Links: 1313770

Description Matt Carrano 2016-06-01 18:34:16 UTC
Created attachment 1163772 [details]
View and Accept Hosts-Initialization in progress

Description of problem:

There is a progress bar that appears in the Hosts list when a click Accept for any unaccepted host in the Create Cluster workflow.  See attached screen shot.  This does not seem to be reporting incremental progress as design and therefore is misleading to the user.  If a progress bar is not possible, replace with just a text message ("Initializing host") since a spinner is already present at the front of the list item.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Go to Create Cluster with one or more unaccepted hosts.
2. Click Accept or Accept All
3. Note progress indicators.

Actual results:
Progress is not reflected.

Expected results:
Progress bar that reflects percentage complete.

Additional info:

Comment 2 :Deb 2016-06-15 14:08:41 UTC
This is an issue which is larger than it appears out-front (aside from removing progress bar, which is easy & necessary).

Will pick this up early next week, post discussion about understanding the issue (why is it taking an eternity to complete) and take correct course of action.

Nishanth, can you please verify with backend devs, whether the delayed response of the acceptance state (started/in progress/success/failed etc at 10min+) is because of the longer sync cycles in the backend?

Comment 3 Nishanth Thomas 2016-06-21 04:59:39 UTC
As MartinB rightly pointed out BZ 1313770 has the the information about how the node initialization works. Also you can have a look at this[1] doc as well

[1]https://docs.google.com/a/redhat.com/document/d/1R4CnO-gMG9YMLJ-nCWKKnr2Vw8Bi2h2zTwO85rHv8g8/edit?usp=sharing

Comment 4 Nishanth Thomas 2016-07-13 18:44:59 UTC
Progress bar replaced with a text message ("Initializing host")

Comment 6 Lubos Trilety 2016-07-28 15:53:20 UTC
Tested on:
rhscon-ceph-0.0.36-1.el7scon.x86_64
rhscon-core-selinux-0.0.36-1.el7scon.noarch
rhscon-core-0.0.36-1.el7scon.x86_64
rhscon-ui-0.0.50-1.el7scon.noarch

No progress bar any more.

Comment 8 errata-xmlrpc 2016-08-23 19:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.