Bug 1341789 - docker build/run fails after upgrade from docker 1.9.1 to 1.10.3
Summary: docker build/run fails after upgrade from docker 1.9.1 to 1.10.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1323934
TreeView+ depends on / blocked
 
Reported: 2016-06-01 18:45 UTC by Martin Jenner
Modified: 2019-03-06 01:14 UTC (History)
4 users (show)

Fixed In Version: docker-1.10.3-28.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-23 16:19:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
journalctl -b -u docker (50.64 KB, text/plain)
2016-06-01 18:59 UTC, Martin Jenner
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1274 0 normal SHIPPED_LIVE docker bug fix and enhancement update 2016-06-23 20:12:28 UTC

Description Martin Jenner 2016-06-01 18:45:33 UTC
Description of problem:

After upgrading a RHEL host running docker 1.9 with images available on the host I can no longer run the original images or build new images.

Version-Release number of selected component (if applicable):

prior to upgrade
# rpm -qa | grep docker
docker-selinux-1.9.1-25.el7.x86_64
docker-forward-journald-1.9.1-25.el7.x86_64
docker-1.9.1-25.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. I installed docker 1.10 directly from brew, all binary rpms.

yum install http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-common-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-forward-journald-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-logrotate-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-lvm-plugin-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-novolume-plugin-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-rhel-push-plugin-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-selinux-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-unit-test-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/docker-v1.10-migrator-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/oci-register-machine-1.10.3-27.el7.x86_64.rpm http://download.eng.bos.redhat.com/brewroot/packages/docker/1.10.3/27.el7/x86_64/oci-systemd-hook-1.10.3-27.el7.x86_64.rpm

2. Example running an image available prior to upgrade, all attempts to run or uild images seem to hit the same issue.

docker run --rm -it registry.access.redhat.com/rhel7.2docker: Error response from daemon: Cannot start container 93b04b32f732cf32f447d3ebc847c53f1639b1d7016d4e51c908dd2798a66b45: [9] System error: exit status 1.

Actual results:
containers did not run our build

Expected results:
able to run existing pulled docker images on the host after upgrade to 1.10


Additional info:

Comment 1 Martin Jenner 2016-06-01 18:59:07 UTC
Created attachment 1163773 [details]
journalctl -b -u docker

journalctl -b -u docker, I trimmed the log to show the start of docker after the upgrade

Comment 2 Daniel Walsh 2016-06-01 19:43:20 UTC
This looks like the unit file is not setup correctly by docker to use the cgroup configs?

Comment 3 Daniel Walsh 2016-06-01 19:43:53 UTC
Lokesh is docker using systemd for its cgroups?

Comment 6 Lokesh Mandvekar 2016-06-02 14:32:38 UTC
I need to add --exec-opt native.cgroupdriver=systemd in the docker unitfile. This was already present in the docker-latest unitfile.

Comment 7 Martin Jenner 2016-06-02 15:15:16 UTC
Verified I can run and build against existing and newly pulled images

# rpm -q docker
docker-1.10.3-28.el7.x86_64

# docker -v
Docker version 1.10.3, build 4779225/1.10.3

# docker run --rm -it registry.access.redhat.com/rhel7.2
[root@98b256c29a0b /]# ls
bin   dev  home  lib64  mnt  proc  run   srv  tmp  var
boot  etc  lib   media  opt  root  sbin  sys  usr
[root@98b256c29a0b /]# exit

Comment 9 errata-xmlrpc 2016-06-23 16:19:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1274


Note You need to log in before you can comment on or make changes to this bug.