Bug 1341819 - Incorrect labels used in Cluster Configuration page
Summary: Incorrect labels used in Cluster Configuration page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2
Assignee: gowtham
QA Contact: Martin Bukatovic
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-01 19:47 UTC by Matt Carrano
Modified: 2016-08-23 19:53 UTC (History)
9 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:53:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
What needs to be fixed (497.10 KB, image/png)
2016-06-07 19:14 UTC, Ju Lim
no flags Details
config screen (117.02 KB, image/png)
2016-07-20 06:58 UTC, Nishanth Thomas
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 283165 None None None 2016-07-13 05:31:18 UTC
Gerrithub.io 283170 None None None 2016-07-13 05:30:34 UTC
Gerrithub.io 284520 None None None 2016-07-20 06:55:04 UTC
Gerrithub.io 284521 None None None 2016-07-20 06:54:43 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Matt Carrano 2016-06-01 19:47:44 UTC
Description of problem:
Some of the labeling in the Cluster Configuration page is incorrect.  See https://docs.google.com/presentation/d/1-3HWjwCcpeeH9Tq2ip9GggQo0I4koWZtfNcmAfogNA8/edit#slide=id.g11293b91de_0_5 for more details.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Go to Clusters list
2.Select a cluster and view details
3.Click on Configuration tab.

Actual results:


Expected results:


Additional info:

Comment 2 Ju Lim 2016-06-07 19:14:38 UTC
Created attachment 1165742 [details]
What needs to be fixed

Comment 3 :Deb 2016-06-15 13:44:41 UTC
The notification and utilization tables (where the problems are identified) are generated from API response data.

As long as we fix them on the backend, they should render fine on the frontend.

Releasing this to be reassigned to backend team.

Comment 4 Shubhendu Tripathi 2016-06-27 05:50:57 UTC
@Deb, backend api returns field names and values. The labels for the fields are hardcoded in UI code. We need to correct as per suggestion.

Comment 7 Martin Bukatovic 2016-07-19 15:02:29 UTC
Checking with rhscon-ui-0.0.48-1.el7scon.noarch

The cluster Configuration tab now reports the following:

Notifications:

* Cluster Availability (no change needed)
* Host Availability (no change needed)
* Quorum Loss (no change needed)
* Monitor Availability (no change needed)
* OSD Availability (fixed)

Thresholds (here the list of items changed compared to state when
the BZ was reported):

* OSD Utilization (not fixed, see below)
* Storage Utilization not fixed, see below)
* Cluster (fixed)
* Storage Profile (fixed)
* Block Device Utilization (not fixed, see below)

Looking at the description from Matt, I see that he proposed 2 types of changes
for the Thresholds (was Utilization) table:

 * fixing typos (such as Osd -> OSD, Cpu -> CPU, Df -> OSD, ...)
 * dropping Utilization from the 1st column of the table
   (eg. Cluster Utilization -> Cluster)

And while I see that the typos were fixed, I still see word "Utilization"
in the 1st column of few lines in the table. Based on Matt's description,
I would expect that it should not be there.

>> ASSIGNED

Comment 9 Shubhendu Tripathi 2016-07-19 17:31:01 UTC
Martin,

As per the typos mentioned in the attached screen shot everything is changed. Wherever he asked to remove "Utilization", its removed.

Also Df is not OSD actually. In reality it is Mount Point utilization so named like this.

As such I don't find anything wrong done as part of fix. Not sure if this is really a FailedQA.

When something suggested in UX guidelines its just a guideline and its dev's responsibility to make sure that Df is not replaced with OSD rather it is Mount Point utilization.

These comments are solely mine... and request Nishanth/Matt to comment.

Comment 10 Martin Bukatovic 2016-07-20 06:48:44 UTC
(In reply to Shubhendu Tripathi from comment #9)
> As such I don't find anything wrong done as part of fix. Not sure if this is
> really a FailedQA.

When I look at "what needs to be fixed" image attached to this BZ, I see that
for every line in the table which contains word "Utilization" in the 1st column,
the design team suggested to remove it. This makes me think that the design team
have removing all occurrences of word "Utilization" in mind. So when I see that
there are lines which contains word "Utilization" in the current implementation,
I consider this to be an issue which should be addressed (by removing the word
"Utilization" from affected lines). Moreover I expect that all lines in the table
are about some kind of utilization, so I don't understand why some name there
includes "Utilization" in it's name while some others don't.

This is the only problem I describe in comment 7.

Comment 11 Nishanth Thomas 2016-07-20 06:58:37 UTC
Created attachment 1181925 [details]
config screen

Comment 14 Shubhendu Tripathi 2016-07-25 12:51:24 UTC
The patches https://review.gerrithub.io/#/c/283170/ and https://review.gerrithub.io/#/c/283165/ remove the "Utilization" keyword from the UI.

Comment 16 Lubos Trilety 2016-07-28 15:37:49 UTC
What about:
Order not logical for Utilization

It seems to me, that nothing was done in the regard, the order is not lexicographical nor logical e.g. for logical one I expect to have swap next to memory.

Comment 17 Lubos Trilety 2016-07-28 15:49:53 UTC
(In reply to Lubos Trilety from comment #16)
> What about:
> Order not logical for Utilization
> 
> It seems to me, that nothing was done in that regard, the order is not
> lexicographical nor logical e.g. for logical one I expect to have swap next
> to memory.

Tested on:
rhscon-ui-0.0.50-1.el7scon.noarch

Comment 18 Lubos Trilety 2016-07-29 12:29:42 UTC
After discussion the order will not be changed.

Comment 20 errata-xmlrpc 2016-08-23 19:53:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.