Bug 1341838 - rhel-osp-director: Deploy with external ceph: "ERROR: The Parameter (GlanceRbdPoolName) was not defined in template"
Summary: rhel-osp-director: Deploy with external ceph: "ERROR: The Parameter (GlanceR...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Giulio Fidente
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-01 20:24 UTC by Alexander Chuzhoy
Modified: 2016-08-11 11:31 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
Old versions of the puppet-ceph-external.yaml Heat environment file are not supported anymore. A newer version of this file is shipped with the 9.0 templates and must be used instead. Any customizations made to the old puppet-ceph-external.yaml file must be ported into the newer version.
Clone Of:
Environment:
Last Closed: 2016-08-11 11:31:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Alexander Chuzhoy 2016-06-01 20:24:24 UTC
rhel-osp-director:  Deploy with external ceph: "ERROR: The Parameter (GlanceRbdPoolName) was not defined in template"


Environment:
openstack-puppet-modules-8.0.4-1.el7ost.noarch
python-gnocchiclient-2.2.0-1.el7ost.noarch
instack-undercloud-4.0.0-2.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-8.el7ost.noarch


Steps to reproduce:
Attempt a deployment of overcloud with external ceph:

openstack overcloud deploy --templates --control-scale 3 --compute-scale 2 --ceph-storage-scale 0    --neutron-network-type vxlan --neutron-tunnel-types vxlan  --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml -e ~/ssl-heat-templates/environments/enable-tls.yaml -e ~/ssl-heat-templates/environments/inject-trust-anchor.yaml -e puppet-ceph-external.yaml


The content of puppet-ceph-external.yaml:
cat puppet-ceph-external.yaml
resource_registry:
  OS::TripleO::CephClusterConfig::SoftwareConfig: /usr/share/openstack-tripleo-heat-templates/puppet/extraconfig/ceph/ceph-external-config.yaml
parameters:
  CephClusterFSID: <ID>
  CephClientKey: <key>
  CephExternalMonHost: <IP>, MIP>, <IP>
  NovaEnableRbdBackend: true
  CinderEnableRbdBackend: true
  GlanceBackend: rbd
  CinderEnableIscsiBackend: false
  GnocchiBackend: rbd
  GlanceRbdPoolName: images
  NovaRbdPoolName: vms
  CinderRbdPoolName: volumes
  GnocchiRbdPoolName: metrics
  CephClientUserName: openstack




Result:
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
ERROR: The Parameter (GlanceRbdPoolName) was not defined in template.

Expected result:
Successfully completed deployment.

Comment 2 Alexander Chuzhoy 2016-06-01 20:33:53 UTC
Note: removing " GlanceRbdPoolName: images" will prompt for error for the next line with RbdPoolName.

Comment 3 Alexander Chuzhoy 2016-06-01 21:03:42 UTC
Removing all RbdPoolName lines errors on:
ERROR: The Parameter (CephClientUserName) was not defined in template.

Comment 5 Alexander Chuzhoy 2016-06-02 01:44:51 UTC
The deployment completed successfully when I placed "CephClientUserName: openstack
" under parameter_defaults.

Comment 6 Jay Dobies 2016-06-08 18:31:48 UTC
Alexander - The parameter_defaults section is the correct place for this, so I'd argue it's working as intended. What concerns me is what made you put it under parameters in the first place, and if we have a potential docs/examples issue that drove you down that path.

Comment 7 Alexander Chuzhoy 2016-06-08 21:27:38 UTC
The use of parameters was a legacy. 
I used to test this scenario in previous versions and assumed it'll work the same.

Comment 9 Giulio Fidente 2016-07-06 15:59:36 UTC
I've attempted a Doc Text describing what can cause this issue and how to avoid it.

Do you think it's enough to close the BZ?

Comment 10 Jaromir Coufal 2016-07-28 17:51:48 UTC
Sasha, can you follow up with verifying if this resolved the issue?

Comment 11 Alexander Chuzhoy 2016-07-29 03:42:51 UTC
Verified:
Environment:
openstack-puppet-modules-8.1.5-1.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-18.el7ost.noarch
instack-undercloud-4.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-18.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-18.el7ost.noarch


[stack@instack ~]$ cat puppet-ceph-external.yaml
resource_registry:
  OS::TripleO::CephClusterConfig::SoftwareConfig: /usr/share/openstack-tripleo-heat-templates/puppet/extraconfig/ceph/ceph-external-config.yaml
parameter_defaults:
  CephClusterFSID: <FSID>
  CephClientKey: <KEY>
  CephExternalMonHost: <LIST of IPs>
  NovaEnableRbdBackend: true
  CinderEnableRbdBackend: true
  GlanceBackend: rbd
  CinderEnableIscsiBackend: false
  GnocchiBackend: rbd
  CephClientUserName: <USERNAME>

Comment 13 errata-xmlrpc 2016-08-11 11:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.