Bug 134197 - joerc and messages i18n not completely
joerc and messages i18n not completely
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: joe (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 00:40 EDT by Wei-Lun Chao
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 11:37:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (22.64 KB, image/png)
2004-10-01 14:45 EDT, Lon Hohberger
no flags Details
joerc exhibiting behavior (25.88 KB, text/plain)
2004-10-01 14:46 EDT, Lon Hohberger
no flags Details
Patch attempt #1 (1.29 KB, patch)
2004-10-01 15:41 EDT, Lon Hohberger
no flags Details | Diff
screen from joe-3.1-3 (83.59 KB, image/png)
2004-10-03 23:29 EDT, Wei-Lun Chao
no flags Details
joerc for last comment (25.88 KB, text/plain)
2004-10-03 23:33 EDT, Wei-Lun Chao
no flags Details
screenshot from joe-3.1-5 (84.19 KB, image/png)
2004-10-05 06:27 EDT, Wei-Lun Chao
no flags Details
New screenshot with real fix. (28.46 KB, image/png)
2004-10-05 12:01 EDT, Lon Hohberger
no flags Details
Joerc with correct "CURSOR" width in help section (fixes formatting from old joercs) (25.88 KB, text/plain)
2004-10-05 12:02 EDT, Lon Hohberger
no flags Details
New patch for joe-3.1-6 (1.71 KB, patch)
2004-10-05 12:04 EDT, Lon Hohberger
no flags Details | Diff
joerc with help messages for zh_TW.UTF-8 (26.48 KB, text/plain)
2004-10-10 04:30 EDT, Wei-Lun Chao
no flags Details

  None (edit)
Description Wei-Lun Chao 2004-09-30 00:40:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.7.3)
Gecko/20040922

Description of problem:
has not introduced gettext function in source.
messages should be excluded from joerc.
utf-8 coded help messages will not be displayed.

Version-Release number of selected component (if applicable):
joe-3.1

How reproducible:
Always

Steps to Reproduce:
1.joe /etc/joe/joerc
2.change some help messages with utf8 coded text
3.joe -help
    

Actual Results:  literal utf8 messages

Expected Results:  correctly interpreted messages

Additional info:
Comment 1 Lon Hohberger 2004-10-01 09:12:02 EDT
So, this is only with the help dialog box, right?
Comment 2 Lon Hohberger 2004-10-01 09:13:14 EDT
Also, could you attach a joerc which causes problems for me?
Comment 3 Lon Hohberger 2004-10-01 14:45:45 EDT
Created attachment 104638 [details]
Screenshot
Comment 4 Lon Hohberger 2004-10-01 14:46:16 EDT
Created attachment 104639 [details]
joerc exhibiting behavior
Comment 5 Lon Hohberger 2004-10-01 14:50:01 EDT
Upstream bug for tracking:

http://sourceforge.net/tracker/index.php?func=detail&aid=1038643&group_id=23475&atid=378598
Comment 6 Lon Hohberger 2004-10-01 15:41:27 EDT
Created attachment 104645 [details]
Patch attempt #1

This patch causes joe to decode the help text output prior to displaying and
counts one UTF-8 glyph as one char for screen size purposes.
Comment 7 Lon Hohberger 2004-10-01 15:49:12 EDT
The 'int ret' variable isn't used in that patch.  However, the rest
should work.

Building new package; state -> MODIFIED
Comment 8 Lon Hohberger 2004-10-01 15:53:35 EDT
This should appear in rawhide as joe-3.1-5
Comment 9 Wei-Lun Chao 2004-10-03 23:29:14 EDT
Created attachment 104697 [details]
screen from joe-3.1-3
Comment 10 Wei-Lun Chao 2004-10-03 23:33:23 EDT
Created attachment 104698 [details]
joerc for last comment
Comment 11 Wei-Lun Chao 2004-10-03 23:54:14 EDT
also suggest include gettext patch from markx_sk in sourceforge.
and then exclude help message from joerc into src.
Comment 12 Lon Hohberger 2004-10-04 15:33:07 EDT
The gettext patch is for joe-2.9.8, and does not apply very well to
3.1.  When a newer version of the patch is built, I'll look in to it.
Comment 13 Wei-Lun Chao 2004-10-05 06:27:38 EDT
Created attachment 104774 [details]
screenshot from joe-3.1-5

better than joe-3.1-3, but still not complete :(
Comment 14 Wei-Lun Chao 2004-10-05 10:37:49 EDT
in terminal, the width of each CJK glyph equal two letters.
could it be the reason, which also sometime causes broken
CJK glyphs in the main edit pane?
Comment 15 Lon Hohberger 2004-10-05 10:45:01 EDT
I don't think there's a clean way to determine the proper width of the
glyph as it's rendered on the screen, but I think the effect that
would have would be to display the whole glyph (and move the edge off
the screen) in this case.

I'll do more looking.


Comment 16 Lon Hohberger 2004-10-05 10:52:16 EDT
Wait, yes there is.

joe_wcwidth()...
Comment 17 Lon Hohberger 2004-10-05 12:01:59 EDT
Created attachment 104786 [details]
New screenshot with real fix.

Screenshot from 3.1-6 patch.
Comment 18 Lon Hohberger 2004-10-05 12:02:47 EDT
Created attachment 104787 [details]
Joerc with correct "CURSOR" width in help section (fixes formatting from old joercs)
Comment 19 Lon Hohberger 2004-10-05 12:04:04 EDT
Created attachment 104788 [details]
New patch for joe-3.1-6

This fixes the previous patch's lack of correct character width support.
Comment 21 Wei-Lun Chao 2004-10-10 04:30:18 EDT
Created attachment 104982 [details]
joerc with help messages for zh_TW.UTF-8

here is another joerc.
before taking a gettext patch, could you make a i18n joerc higher priority?
that is, joe looks for:
1. $HOME/.joerc.$LANG
2. $HOME/.joerc
3. /etc/joe/joerc.$LANG
4. /etc/joe/joerc
Comment 22 Lon Hohberger 2004-10-11 09:54:37 EDT
I was not going to take the gettext patch.  The patch is against
2.9.8, and 3.1 is *very* different from 2.9.8 (such as, 2.9.8 does not
have UTF-8 support).

I'm going to submit joerc.zh_TW.UTF-8 upstream.  All of the other text
files need to be converted to all the different languages too
(jpicorc, jmacsrc, etc.).
Comment 23 Lon Hohberger 2004-10-11 11:37:37 EDT
The author of joe is going to create a contrib directory and place the
joerc.zj_TW.UTF-8 there.  He's also got it on his roadmap to implement
gettext support.

Apparently, others are working on separating the help text out of
joerc so that it can be internationalized as well.

As others are already working on this, I'm closing this 'UPSTREAM'.

Note You need to log in before you can comment on or make changes to this bug.