Bug 1342006 - upgrade stomppy to version 4.*
Summary: upgrade stomppy to version 4.*
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: stomppy
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-02 09:11 UTC by Cristovao Cordeiro
Modified: 2016-06-03 13:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-03 13:00:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Cristovao Cordeiro 2016-06-02 09:11:48 UTC
Description of problem:
 - the current stomppy version available is 3.1.6. The major release 4 was already released and it seems not to be completely backward compatible. Example: the "connect" method.


Version-Release number of selected component (if applicable):
Version     : 3.1.6
Release     : 2.el7


How reproducible:
Just execute the following steps with both the current stomppy version and then 4.*

Steps to Reproduce:
1. import stomp
2. conn = stomp.Connection([(url, port)])
3. conn.start()
4. conn.connect(user,pwd)

Actual results:
With the current 3.* version:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: connect() takes at most 2 arguments (3 given)

Expected results:


Additional info:

Comment 1 Steve Traylen 2016-06-03 07:53:11 UTC
Your example demonstrates it is not forward compatible.

But indeed


https://github.com/jasonrbriggs/stomp.py/blob/master/CHANGELOG#L202

version 4.0 states it's not backwards compatible so as a simple upgrade
within EPEL this is not possible unless there is a super good reason.


Do you actually need stomp version 1.2 which is the only new feature,
can you not just use the version 3 construct?

If still needed can looking at doing a new stomppy4 package.

Comment 2 Cristovao Cordeiro 2016-06-03 07:58:47 UTC
I can work around then for this use case.

But nevertheless the upgrade/new package should be at some point right?

Comment 3 Steve Traylen 2016-06-03 13:00:20 UTC
Not within the life time of RHEL7, RHEL8 will have the latest.

Unless a good reason or the existing one is so broken that it's
easier to blast it away and start again but we are not in that category
here.

Steve.


Note You need to log in before you can comment on or make changes to this bug.