Bug 134203 - hotkey menu failed to respond to numeric input
hotkey menu failed to respond to numeric input
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-09-30 02:06 EDT by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: im-sdk-12.0.1-12.svn1943
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 03:32:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-09-30 02:06:52 EDT
Description of problem:
After activating the helpkey menu, select any LE from the menu does
not  work except CannaLE.

Version-Release number of selected component (if applicable):
12.0.1-9.svn1936

How reproducible:
Always

Steps to Reproduce:
1.install latest im-sdk
2.in the zh_CN locale
3.activate hotkey menu (ctrl-shift-SPACE)
4.enter the number beside any LE except CannaLE (1-9)
  
Actual results:
No response

Expected results:
LE changed

Additional info:
To select CannaLE from hotkey, 
- ctrl-shift-space
- 1 (number)
- backspace
Comment 1 Lawrence Lim 2004-09-30 02:09:04 EDT
Some additional information

--------
[root@engtester leif]# ls -la
total 456
drwxr-xr-x  2 root root   4096 Sep 30 14:21 .
drwxr-xr-x  9 root root   4096 Sep 30 14:16 ..
-rwxr-xr-x  1 root root  23396 Sep 28 23:22 CannaLE.so
-rwxr-xr-x  1 root root 249696 Sep 30 09:48 chinput.so
-rwxr-xr-x  1 root root  21048 Sep 28 23:22 FreeWnnLE.so
-rwxr-xr-x  1 root root  31228 Sep 28 23:22 hangul.so
-rwxr-xr-x  1 root root  44396 Sep 28 23:22 thaile.so
-rwxr-xr-x  1 root root  41708 Sep 28 23:22 unitle.so
[root@engtester leif]# rpm -qa |grep iiimf
iiimf-server-12.0.1-9.svn1936
iiimf-le-hangul-12.0.1-9.svn1936
iiimf-emacs-12.0.1-9.svn1936
iiimf-x-12.0.1-9.svn1936
iiimf-libs-12.0.1-9.svn1936
iiimf-docs-12.0.1-9.svn1936
iiimf-le-canna-12.0.1-9.svn1936
iiimf-libs-devel-12.0.1-9.svn1936
iiimf-le-chinput-0.3-10
iiimf-le-unit-12.0.1-9.svn1936
iiimf-gtk-12.0.1-9.svn1936
iiimf-le-sun-thai-12.0.1-9.svn1936
iiimf-qt-12.0.1-7.svn1891
iiimf-gnome-im-switcher-12.0.1-9.svn1936
iiimf-le-chinput-debuginfo-0.3-10
iiimf-csconv-12.0.1-9.svn1936
iiimf-le-freewnn-12.0.1-9.svn1936
Comment 2 Lawrence Lim 2004-09-30 03:11:55 EDT
Also like to add that after failing to respond. The hotkey menu will
attached to the active application and the hotkey menu cannot be
closed or removed. The application has to be shut down to destroy the
menu. 

Not sure if this is related or should I file another bug?
Comment 3 Akira TAGOH 2004-09-30 11:59:55 EDT
should be fixed in 12.0.1-10.svn1943. please try.
Comment 4 Lawrence Lim 2004-09-30 22:49:08 EDT
Comfirmed most of the issue such as:
1) responding to arrow keys
2) accept RETURN after entry highlight

However, slight issue, hotkey menu now has some problem accepting
Numeric selection. Hence, to select CannaLE, one has to enter 1
(committed to the application, not very ideal) followed by BACKSPACE.
Comment 5 Akira TAGOH 2004-10-01 05:45:26 EDT
selecting LE by the numeric key works for me, though. have you
restarted the gtk2 applications or httx after upgrading?
Comment 6 Lawrence Lim 2004-10-05 03:32:47 EDT
Confirmed fixed. Tested with im-sdk-12.0.1-12.svn1943.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.