Bug 134209 - hangul input method for classic chinese have error/missing characters
hangul input method for classic chinese have error/missing characters
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-09-30 03:06 EDT by Kyuso Cahi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 10:30:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyuso Cahi 2004-09-30 03:06:01 EDT
Description of problem:

When trying to type classic chinese characters from Hangul input
method, I see many missing (blank) characters, and some erroneous
characters (wrong definitions.)

Version-Release number of selected component (if applicable):
iiimf-le-hangul-11.4-46.1

How reproducible:
always

Steps to Reproduce:
1. run any gnome or kde program (preferably an editor)
2. press CTRL-SPACE, type 'whd', press F9
3. 

Actual results:

Several classic chinese characters show up as blank, with definitions.
One character is erroneously defined, e.g., the character for
'swe-book Chong' is supposed to be the previous character shown as
'alcoholic drink bottle' ('sool-byeong Chong'); I didn't check
thoroughly since I am not fully versed with many chinese characters.

Expected results:
All classical chinese characters should show up, and all definitions
should match correctly.

Additional info:
FC1 input method ami had perfect list of classical chinese characters
(it doesn't show any definitions, so may had less bug). Even FC2 emacs
built-in mule's hangul input method works as good as ami, with no
missing classical chinese.
Comment 1 Lawrence Lim 2004-09-30 03:21:27 EDT
iiimf-le-hangul is part of im-sdk package. 

Reassigning.
Comment 2 Leon Ho 2004-09-30 23:48:50 EDT
For the missing char:
  - I am testing against nabi (which is XIM input method and they are
both using ttf), they are showing the similar behavior.

My take is that ami and emacs are using old bitmap fonts that why the
coverage of the fonts are different.

Can you use ami to enter the missing character from candidate window
into gedit and see if it shows? screenshot will be great.
Comment 3 Kyuso Cahi 2004-10-02 10:30:26 EDT
I tested FC1 ami and emacs, FC2 nabi and emacs, and found the
following observation:

Both ami and emacs of either FC1/FC2 has shorter list of classical
chinese than iiimf. This must mean that iiimf has much more list of
characters, even missing ones that don't exist in Korean.

My conclusion: it's not a bug, but iiimf added more chinese characters
than Korean standard list of classical chinese characters they use. I
am closing this bug as resolved.

Thank you for the quick response.

Note You need to log in before you can comment on or make changes to this bug.