Bug 134210 - hangul input method display not cleanly shown from xterm/gnome-terminal
hangul input method display not cleanly shown from xterm/gnome-terminal
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-09-30 03:19 EDT by Kyuso Cahi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 21:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyuso Cahi 2004-09-30 03:19:50 EDT
Description of problem:

When typing hangul from xterm or gnome-terminal, the cursor and
inserted/moved letters do not show up properly, especially when using
tcsh command line editing.

Version-Release number of selected component (if applicable):
iiimf-le-hangul-11.4-46.1
xterm-179.6-EL
gnome-terminal-2.6.0-2
tcsh-6.12-8

How reproducible:
always

Steps to Reproduce:
1. choose Hangul language from KDE or GNOME
2. from a terminal window running tcsh, type CTRL-SPACE, type some letters
3. press back arrow or CTRL-A to move cursor to prompt, type more letters
  
Actual results:
The cursor doesn't sit right next to the prompt, but slightly to the
left overlapping the prompt. When letters are inserted, either
square-boxed characters are printed or proper letters are printed, and
they fill in both directions instead of being shown as inserting at
the cursor to the right.


Expected results:
The cursor position and insertion of letters should work as in any
editing mode without overdrawing onto prompt or existing letters, with
propler letters instead of boxes.

Additional info:

FC1 ami input method never had this problem when using xterm. The
following are the fonts used in xterm
xterm*vt100*Font: 
-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso10646-1
xterm*vt100*wideFont:
-misc-fixed-medium-r-normal-ja-13-120-75-75-c-120-iso10646-1

FC2
Comment 1 Akira TAGOH 2004-09-30 09:59:06 EDT
reassigning to proper package and owner.
Comment 2 Yu Shao 2004-09-30 20:46:20 EDT
When you cat a Korean text file on gnome-terminal, do you see the same
problem? I am just wondering if this is the problem with input method.
Comment 3 Kyuso Cahi 2004-10-02 10:44:06 EDT
Yes, it echos exactly what I typed, rather than what is shown. The
input method is working perfectly. It is the way xterm or
gnome-terminal display processing of command-line editing is messed up.

I found FC1 xterm/gnome-terminal behaves exactly the same way as in
FC2, so my conclusion is that the display of command line editing has
not been updated since old days of English-only terminals, and not
moving cursor position properly when displaying TT fonts with asian
characters, although I haven't tested Chinese or Japanese command line
editing from terminals. You only need to use back arrow or CTRL-A to
see how the cursor moves into wrong places.

hanterm used to properly move the cursor to the right position and
display characters properly, but is no longer included in Fedora Core.
I think the same is with kterm or cterm.
Comment 4 Kyuso Cahi 2004-10-02 13:37:24 EDT
Just to clarify my comments, cat of a file works fine. It's only the
editing that messes things up, such as backspace on a syllable/chinese
character only erases half of the character, and moving cursor using
arrows only moves half way of a character or even jumps too far to the
left.

I think xterm/gnome-terminal is still using some 8-bit character
editing to compute cursor position in movement, deletion, and
insertion of 16-bit characters.

Most of other gnome/kde applications behave properly, so it's only
with the terminal software and some others not correctly interfacing
with input methods.

Since hanterm et al are no longer in Fedora Core, I am hoping at least
the terminal software would have been properly updated.

So the problem must be xterm and gnome-terminal or some libraries they
use, or it could be the shell program (tcsh, bash, etc.) that uses
some libraries for command-line editing that is not behaving as it should.
Comment 5 Leon Ho 2004-10-10 22:41:11 EDT
I tried to reproduce it in gnome-terminal 2.7.3-2 and vte 0.11.11-5
but i can able to cursoring through character and delete does delete
the whole character. Can you reproduce on those version?

test case:
- LANG=ko_KR.UTF-8 gnome-terminal --disable-factory
- ctrl-space
- "rkskek" + space
- back arrows
- delete one of the char

Note You need to log in before you can comment on or make changes to this bug.