Bug 1342181 - The vmhgfs-fuse component of open-vm-tools interacts poorly with git
Summary: The vmhgfs-fuse component of open-vm-tools interacts poorly with git
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: open-vm-tools
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ravindra Kumar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-02 15:54 UTC by Kevin L. Mitchell
Modified: 2016-09-19 00:19 UTC (History)
4 users (show)

Fixed In Version: open-vm-tools-10.0.5-4.fc24 open-vm-tools-10.0.5-4.fc25 open-vm-tools-10.0.5-4.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-16 23:19:23 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1579544 None None None 2016-06-02 15:54:33 UTC

Description Kevin L. Mitchell 2016-06-02 15:54:33 UTC
Description of problem:

git encounters intermittent index corruption when updating the index.

Version-Release number of selected component (if applicable):

open-vm-tools-10.0.5-2.fc23.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Launch a Fedora 23 image on VMWare Fusion on a Mac
2. Mount a share using vmhgfs-fuse
3. Attempt two rapid updates of the index, e.g., two "git add" commands

Actual results:

An obscure error regarding corruption in the index.

Expected results:

Normal behavior.

Additional info:

This apparently has been reported less than a month ago; opening this bug to ensure that the fix will get picked up in Fedora once one is available.  Links to the two relevant bugs:

* https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1579544
* https://github.com/vmware/open-vm-tools/issues/90

Comment 1 Ravindra Kumar 2016-06-02 21:03:12 UTC
This will be fixed in the next update of open-vm-tools.

Comment 2 Kevin L. Mitchell 2016-06-24 15:48:21 UTC
I noticed an update to open-vm-tools today in Fedora 23, so I installed and restarted my vm.  However, I am still seeing the same index corruption behavior in git repositories, so this issue has not yet been fixed in open-vm-tools-10.0.5-3.fc23.x86_64.

(I note I have not seen any updates to the above bugs, either, so I presume the upstream has not released a fix.  In any case, if the -3 revision was intended to apply a patch to fix the issue, it was unsuccessful in fully resolving it.)

Comment 3 Ravindra Kumar 2016-06-24 18:53:29 UTC
Oops, I meant to say next release of open-vm-tools upstream. Sorry for the confusion.

Comment 4 Kevin L. Mitchell 2016-06-24 19:25:50 UTC
Do you have any idea when that may be?

Comment 5 Ravindra Kumar 2016-06-24 21:39:25 UTC
(In reply to Kevin L. Mitchell from comment #4)
> Do you have any idea when that may be?

I'm afraid I won't be able to talk about that. However, the patch seems pretty easy and I will try to get it in Fedora next week instead of waiting for the open-vm-tools release which might take a while.

Comment 6 Kevin L. Mitchell 2016-06-28 16:00:23 UTC
For the record, I upgraded my VM to Fedora 24 and tried using git with it.  I found the same intermittent corruption bug with open-vm-tools-10.0.5-3.fc24.x86_64, though it's become a little more difficult to reproduce—previously, two consecutive "git add" operations within less than 5 seconds would trigger it, but now it seems a bit less predictable than that; indeed, my initial testing on a toy repository didn't encounter the problem at all, but subsequent work on a real repository did intermittently encounter the problem.  Waiting eagerly for Ravindra's patch to get in :)

Comment 7 Kevin L. Mitchell 2016-07-18 14:49:19 UTC
Is there any update on resolving this bug?  Last I heard, Ravindra was going to try to upload a patch to open-vm-tools to resolve it, but I've not seen any updates that do.

(Side note: I have updated to Fedora 24 since I reported this issue, and the issue is present in that version as well.)

Comment 8 Ravindra Kumar 2016-07-18 17:54:16 UTC
(In reply to Kevin L. Mitchell from comment #7)
> Last I heard, Ravindra was going to try to upload a patch to open-vm-tools to
> resolve it, but I've not seen any updates that do.

Sorry for the delay Kevin. I was occupied with other stuff. I will try to prioritize it this week. Thanks for your understanding.

Comment 9 Kevin L. Mitchell 2016-07-18 17:57:47 UTC
No worries; I understand about being occupied with other stuff :)  Thanks for trying to prioritize it…

Comment 10 Kevin L. Mitchell 2016-07-27 14:55:08 UTC
Just checking in.  I know Ravindra has been busy, but this issue is being a hindrance to me, so I need to be the squeaky wheel and keep checking up on it…

Comment 11 Kevin L. Mitchell 2016-08-04 14:54:47 UTC
Is there any update on resolving this bug?

Comment 12 Kevin L. Mitchell 2016-08-11 14:27:52 UTC
Are there any updates regarding the resolution of this bug?

Comment 13 Ravindra Kumar 2016-08-15 20:39:48 UTC
Sorry for the delay Kevin. Don't intend to commit anything but will try best to get to it this week. Thanks for your patience.

Comment 14 Kevin L. Mitchell 2016-09-12 20:06:13 UTC
Just checking in on this.  I've been otherwise occupied for the past month, but I had a reminder that this issue is still a problem for me.  Any updates on resolving it?

Comment 15 Ravindra Kumar 2016-09-14 00:58:42 UTC
Sorry for the delay, Kevin.

I'm on it now. I should have something ready for by tomm. Thanks for your patience with this!

Comment 16 Fedora Update System 2016-09-14 23:02:13 UTC
open-vm-tools-10.0.5-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5a3400be4

Comment 17 Fedora Update System 2016-09-14 23:07:13 UTC
open-vm-tools-10.0.5-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-89127ad1bb

Comment 18 Fedora Update System 2016-09-14 23:08:32 UTC
open-vm-tools-10.0.5-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b953164815

Comment 19 Ravindra Kumar 2016-09-14 23:25:06 UTC
Kevin, could you please verify that fix works for you? If you provide your "karma" on the update, that will help me push the update to stable repository sooner. Thanks!

Comment 20 Kevin L. Mitchell 2016-09-15 17:16:55 UTC
That does seem to fix my issue.  Yay!

Comment 21 Ravindra Kumar 2016-09-15 19:33:45 UTC
Thanks for the confirmation Kevin!

Comment 22 Fedora Update System 2016-09-16 00:53:36 UTC
open-vm-tools-10.0.5-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b953164815

Comment 23 Fedora Update System 2016-09-16 00:54:04 UTC
open-vm-tools-10.0.5-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-89127ad1bb

Comment 24 Ravindra Kumar 2016-09-16 01:16:45 UTC
Kevin, my fc24 update failed the upgrade test https://taskotron.fedoraproject.org/artifacts/all/0cb23896-7baa-11e6-a663-525400120b80/task_output/open-vm-tools-10.0.5-4.fc24.log because open-vm-tools-10.0.5-4.fc25 hasn't made to stable yet. Could you please provide your karma on fc25 update https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5a3400be4 as well? Thanks!

Comment 25 Fedora Update System 2016-09-16 01:24:50 UTC
open-vm-tools-10.0.5-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5a3400be4

Comment 26 Kevin L. Mitchell 2016-09-16 13:43:45 UTC
Looks like pwalter beat me to it :)

Comment 27 Ravindra Kumar 2016-09-16 20:59:05 UTC
Thanks Kevin and pwalter!

Comment 28 Fedora Update System 2016-09-16 23:19:20 UTC
open-vm-tools-10.0.5-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2016-09-17 00:57:18 UTC
open-vm-tools-10.0.5-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2016-09-19 00:19:47 UTC
open-vm-tools-10.0.5-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.