Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1342283 - Higher static CPU Usage on 5.6.0.9 vs 5.5.4.2 evmserver.rb vs MIQ Server
Summary: Higher static CPU Usage on 5.6.0.9 vs 5.5.4.2 evmserver.rb vs MIQ Server
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: dmetzger
QA Contact: Pradeep Kumar Surisetty
URL:
Whiteboard: perf
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-02 20:55 UTC by Alex Krzos
Modified: 2018-01-05 23:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Appliance CPU Usage + Per Process Miq Server CPU Usage (208.93 KB, application/zip)
2016-06-02 20:55 UTC, Alex Krzos
no flags Details
57102's MIQ Server User avg over 30 minutes screenshot (102.16 KB, image/png)
2017-02-20 20:16 UTC, Archit Sharma
no flags Details
57102's Appliance CPU usage screenshot (82.27 KB, image/png)
2017-02-20 20:18 UTC, Archit Sharma
no flags Details

Description Alex Krzos 2016-06-02 20:55:01 UTC
Created attachment 1164229 [details]
Appliance CPU Usage + Per Process Miq Server CPU Usage

Description of problem:
I am noticing a bit more than normal cpu usage occurring when appliances are idling on infrastructure with 5.6 appliances vs 5.5 appliances.  Digging through per process metrics the additional cpu usage appears to be originating from MIQ Server (5.6) when compared to evm_server.rb(5.5)


When viewing all vcpus usage summed together (0-400% on 4vcpu default appliance) I am seeing an average of 5% more cpu usage.  This appears to be attributed to the Miq Server process when compared to evm_server.rb.  

See attached graphs for details, Node1 is 5.5.4.2 and Node2 is 5.6.0.9 

Version-Release number of selected component (if applicable):
5.6.0.9

How reproducible:


Steps to Reproduce:
1. Deploy idle appliances and review average cpu usage of the two processes compared over time.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Archit Sharma 2017-02-20 20:16:19 UTC
Created attachment 1255865 [details]
57102's MIQ Server User avg over 30 minutes screenshot

Comment 3 Archit Sharma 2017-02-20 20:18:19 UTC
Created attachment 1255866 [details]
57102's Appliance CPU usage screenshot

Comment 4 Archit Sharma 2017-02-20 20:22:42 UTC
FYI, for a 5.7.1.0.2 appliance to be compared with the results above, I'm attaching the screenshots for:

1. avg of User CPU values on a default idling appliance with 4 vcpus, over 30 minutes. In latest version, this appears to be much higher than what we see in 5.5x / 5.6x.

2. similarly calculated average of MIQServer User's CPU value, which is almost equivalent to its 5.6x mate, but higher than 5.5x, as per the screenshots in #c0

Attachments:
- https://bugzilla.redhat.com/attachment.cgi?id=1255865
- https://bugzilla.redhat.com/attachment.cgi?id=1255866

Comment 5 Chris Pelland 2017-08-21 13:08:16 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 6 Chris Pelland 2017-08-21 13:10:25 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.