Bug 134238 - DRI missing from XFree86-4.3.0-62 to XFree86-4.3.0-68
DRI missing from XFree86-4.3.0-62 to XFree86-4.3.0-68
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 10:54 EDT by John Bullock
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 07:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bullock 2004-09-30 10:54:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
When running glxgears after updating to XFree86-4.3.0-68, the
following is displayed:
Xlib: extension "XFree86-DRI" missing on display ":0.0"

This occurred following an up2date from 62 to 68 of the XFree modules.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-68

How reproducible:
Always

Steps to Reproduce:
1.run glxgears in XFree86-4.3.0-62 (no warning)
2.up2date to XFree86-4.3.0-68 
3.run glxgears (Xlib warning)
    

Actual Results:  Xlib: extension "XFree86-DRI" missing on display ":0.0"

Expected Results:  No warning display, only performance data

Additional info:

Nvidia Quadro Card's with 6105 drivers from dell.
Comment 1 Mike A. Harris 2004-10-05 07:32:18 EDT
Nvidia's drivers overwrite XFree86 supplied X server modules
with custom proprietary modules specific to their hardware,
however they are not installed properly via rpm, so this causes
an rpm inconsistency.

Later, if you upgrade XFree86, it will put the XFree86 supplied
module back.  In this case, it is the GLX module (libglx.a) which
gets overwritten.  Since the XFree86 supplied GLX module is
for DRI, when you try to run OpenGL applications under the
proprietary Nvidia driver, this will cause the XFree86 GLX
to be opened, which then attempts to use the DRI extension,
however the proprietary Nvidia driver uses it's own proprietary
interface which requires Nvidia's proprietary GLX, so you
see this error message.

The solution to this problem, is to either use Nvidia proprietary
drivers in rpm package format, such as those available from
livna.org, or to just reinstall the proprietary driver every
time you upgrade XFree86, which will cause the Nvidia GLX to
be reinstalled.

If you require further assistance, please contact the hardware
vendor for technical support.

Setting status to "NOTABUG" (this is a common proprietary driver
installation and configuration issue)


Note You need to log in before you can comment on or make changes to this bug.