Bug 1342408 - JWS access_log is not collected by fluentd
Summary: JWS access_log is not collected by fluentd
Status: CLOSED DUPLICATE of bug 1340785
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: Wang Haoran
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-03 08:37 UTC by Alexander Koksharov
Modified: 2016-07-19 15:42 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-19 15:42:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker CLOUD-57 Major Closed Tomcat's access log valve logs to file in container 2017-07-25 14:38 UTC
Red Hat Bugzilla 1340785 None None None 2016-06-06 14:05 UTC

Description Alexander Koksharov 2016-06-03 08:37:21 UTC
Description of problem:
JWS image stores access logs in /opt/webserver/logs. These logs regords do not appear in EFK.


Version-Release number of selected component (if applicable):


How reproducible:
issue is permanent

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
access logs can be checked through Kibana,



Additional info:

Comment 1 Ben Parees 2016-06-05 02:04:50 UTC
Kevin, I assume we'd just advise users to configure JWS to send the access logs to stdout if they want them in EFK, but not sure if you want to make that the default?

Comment 2 kconner 2016-06-06 14:04:37 UTC
Unfortunately you can't send them to standard out, which is the problem.   The access log is not part of the normal logging as it uses a Valve to create the logs.

Comment 3 Eric Rich 2016-07-19 15:42:35 UTC

*** This bug has been marked as a duplicate of bug 1340785 ***


Note You need to log in before you can comment on or make changes to this bug.