Bug 1342418 - Volume limit error in Horizon when integrating keystone with AD
Summary: Volume limit error in Horizon when integrating keystone with AD
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: 8.0 (Liberty)
Assignee: Martin Lopes
QA Contact: Don Domingo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-03 08:51 UTC by AlbertoG
Modified: 2016-09-06 11:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-06 11:33:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description AlbertoG 2016-06-03 08:51:22 UTC
Description of problem:
Following the document "https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/integrate-with-identity-service/chapter-1-active-directory-integration" to configure AD integration in a Red Hat Openstack Platform 8 deployed by the OSP-d leads into issues when using Horizon. When using the dashboard logged as an AD user and clicking in Network - > routers an error appears (can't get the volume limits) in the dashboard. This is caused because that API call (querying the volume limits) does not work if cinder-api is not configured to authenticate to keystone v3.

The solution is to add/change those parameters in cinder.conf

[keystone_authtoken]
auth_uri = http://keystonevip:5000/v3
auth_version = v3


Version-Release number of selected component (if applicable):
Red Hat Openstack 8

How reproducible:


Steps to Reproduce:
1.Install Red Hat Openstack Platform 8 with OSP-d
2.Follow the document "https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/integrate-with-identity-service/chapter-1-active-directory-integration" to integrate keystone with AD
3.Log in the dashboard as an AD user
4.Click on Network -> Routers

Actual results:
Volume limits error appears

Expected results:
No errors

Additional info:

Comment 4 Andrew Dahms 2016-06-29 06:31:34 UTC
Setting flags.

Comment 10 Andrew Dahms 2016-09-06 11:33:55 UTC
This content is now live on the Customer Portal.

Closing.


Note You need to log in before you can comment on or make changes to this bug.