Bug 1342430 - Cloud network manager availability zones back button redirects me to cloud provider
Summary: Cloud network manager availability zones back button redirects me to cloud pr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Ladislav Smola
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:provider
Depends On:
Blocks: 1371270
TreeView+ depends on / blocked
 
Reported: 2016-06-03 09:11 UTC by Matouš Mojžíš
Modified: 2018-04-10 12:06 UTC (History)
8 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1371270 (view as bug list)
Environment:
Last Closed: 2017-01-11 19:57:43 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Matouš Mojžíš 2016-06-03 09:11:05 UTC
Description of problem:
Similar to: https://bugzilla.redhat.com/show_bug.cgi?id=1342231

Version-Release number of selected component (if applicable):
5.6.0.9

How reproducible:
Always

Steps to Reproduce:
1. Network->Providers-> Select network provider
2. Click on availability zones in summary page
3. Click on back button

Actual results:
It redirects me to Cloud provider summary page.

Expected results:
It should redirect me to network manager summary page.

Additional info:

Comment 2 Harpreet Kataria 2016-06-03 15:09:57 UTC
Ladas,

Is this similar issue as in https://bugzilla.redhat.com/show_bug.cgi?id=1342231
Let me know.

~Harpreet

Comment 3 Ladislav Smola 2016-06-03 15:38:22 UTC
Yes, it's the same

Comment 5 CFME Bot 2016-08-25 22:00:51 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/aae0f095cf48a0db92409fefd34265859b12f4ea

commit aae0f095cf48a0db92409fefd34265859b12f4ea
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Aug 25 13:18:25 2016 +0200
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Thu Aug 25 13:23:35 2016 +0200

    Remove CloudManager relations from a NetworkManager
    
    Remove CloudManager relations from a NetworkManager, those
    relations are available through parent cloud manager link.
    having them in NetworkManager is confusing the back button
    in the nested lists.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1342430

 app/helpers/ems_network_helper/textual_summary.rb | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)

Comment 6 Ladislav Smola 2016-08-26 08:21:12 UTC
QE note: the nested list was removed, since the back button would not work. You can access availability zones by going through parent cloud manager link.

Comment 12 Matouš Mojžíš 2018-04-10 12:06:33 UTC
One time issue. Setting qe_test_coverage flag to -.


Note You need to log in before you can comment on or make changes to this bug.