Bug 1342480 - RBD on EC pool
Summary: RBD on EC pool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2
Assignee: kamlesh
QA Contact: Martin Bukatovic
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-06-03 11:13 UTC by Lubos Trilety
Modified: 2016-08-23 19:54 UTC (History)
9 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:54:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of "Add Block Storage" page (57.50 KB, image/png)
2016-06-29 17:02 UTC, Martin Bukatovic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-06-03 11:13:24 UTC
Description of problem:
During RBD creation it's possible to choose EC pool as the one on which the rados block device will be. It will fail because ceph does not support this. However UI should not offer creating RBD on EC pool at all.

Version-Release number of selected component (if applicable):
rhscon-ui-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-core-0.0.21-1.el7scon.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create some EC pool
2. Try to create rados block device

Actual results:
It's possible to choose created EC pool as the one on which the RBD should be. Moreover if an option about creating a new pool is checked, it's possible to choose that an EC pool should be created.

Expected results:
RBD creation should not offer any EC pool.

Additional info:

Comment 1 Ju Lim 2016-06-07 18:45:36 UTC
Looks like this is a matter of not exposing pools that are erasure coded in the existing pools selection, and only showing the standard/replicated pools.

Comment 2 Martin Bukatovic 2016-06-29 17:02:46 UTC
Created attachment 1174054 [details]
screenshot of "Add Block Storage" page

Checking with:

~~~
# rpm -qa rhscon*
rhscon-ui-0.0.42-1.el7scon.noarch
rhscon-core-0.0.28-1.el7scon.x86_64
rhscon-ceph-0.0.27-1.el7scon.x86_64
rhscon-core-selinux-0.0.28-1.el7scon.noarch
~~~

And I see that Erasure Coded type is still available in "Add Block Storage"
wizard when one selects "Create new pool".

=> MODIFIED

Comment 3 Martin Bukatovic 2016-06-29 17:04:35 UTC
grep 's/MODIFIED/ASSIGNED/' comment 2

Setting this BZ back into ASSIGNED state based on verification fail as explained
in comment 2.

Comment 4 Martin Bukatovic 2016-07-15 16:23:27 UTC
Testing with: rhscon-ui-0.0.48-1.el7scon.noarch

I see no change compared to rhscon-ui-0.0.42-1.el7scon.noarch (as described in
comment 2): I can still select EC pool with "Create new pool" RBD option.

Moving back to MODIFIED

Comment 5 Martin Bukatovic 2016-07-15 16:26:32 UTC
ah, grep 's/MODIFIED/ASSIGNED/' (again)

Comment 6 Martin Kudlej 2016-08-04 12:34:01 UTC
Tested with
ceph-ansible-1.0.5-31.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.39-1.el7scon.x86_64
rhscon-core-0.0.39-1.el7scon.x86_64
rhscon-core-selinux-0.0.39-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch
and it works.

Comment 8 errata-xmlrpc 2016-08-23 19:54:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.