Bug 1342492 - eric: eric requires both Python 2 and Python 3
Summary: eric: eric requires both Python 2 and Python 3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eric
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3 PYTHON3-PYTHON2
TreeView+ depends on / blocked
 
Reported: 2016-06-03 11:42 UTC by Tomas Orsava
Modified: 2016-06-03 12:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-03 12:02:47 UTC


Attachments (Terms of Use)

Description Tomas Orsava 2016-06-03 11:42:58 UTC
The eric RPM requires both Python 2 and Python 3.

Except in very special circumstances, there is no need for one package
to drag in both Python stacks. Usually, this is a packaging error: for
example, a stray "/usr/bin/python" shebang in a Python 3 package can
introduce a Python 2 dependency.

Please split your package, or remove the stray dependencies.
There is a section on shebangs in the Python RPM Porting Guide [0]
which covers this issue.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing this issue!


[0] http://python-rpm-porting.readthedocs.io/en/latest/application-modules.html#are-shebangs-dragging-you-down-to-python-2

Comment 1 Rex Dieter 2016-06-03 12:02:47 UTC
For now, this is intended and by design.

For some future iteration of the package, we may consider doing otherwise (using rich/soft dependencies).

Comment 2 Tomas Orsava 2016-06-03 12:16:50 UTC
Oh, I see! For a Python IDE it does make sense.

My apologies and have a great day!


Note You need to log in before you can comment on or make changes to this bug.