Bug 1342549 - LibreOffice 5.0.6 crashes after pressing ESC key in search function
Summary: LibreOffice 5.0.6 crashes after pressing ESC key in search function
Keywords:
Status: CLOSED DUPLICATE of bug 1343766
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1344040 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-03 13:50 UTC by Adri Verhoef
Modified: 2016-06-13 20:15 UTC (History)
7 users (show)

Fixed In Version: libreoffice-5.0.6.2-6.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-08 10:34:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Adri Verhoef 2016-06-03 13:50:07 UTC
Description of problem:
LibreOffice crashes right after you type the escape key in the search function of oocalc and ooffice.

Version-Release number of selected component (if applicable):
libreoffice-core-5.0.6.2-5.fc23.x86_64

How reproducible:
By opening a file, starting the search function and then typing the escape key.

Steps to Reproduce:
1. Start oocalc or ooffice and open a file.
2. Type Ctrl-F to start the search function.
3. Type the ESCAPE key.

Actual results:
LibreOffice crashes.

Expected results:
Expecting LibreOffice to leave the search function, not crashing.

Additional info:
(After crashing, LibreOffice restarts, offering to recover the data, like normal.)
Tested this both with an existing and with a newly created file for the occasion.

Comment 1 Caolan McNamara 2016-06-06 20:19:24 UTC
reproducible

Comment 2 Fedora Update System 2016-06-07 13:05:08 UTC
libreoffice-5.0.6.2-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-21818bf884

Comment 3 Fedora Update System 2016-06-08 02:23:59 UTC
libreoffice-5.0.6.2-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-21818bf884

Comment 4 Caolan McNamara 2016-06-08 10:34:41 UTC
insufficient fix

*** This bug has been marked as a duplicate of bug 1343766 ***

Comment 5 Fedora Update System 2016-06-08 22:52:24 UTC
libreoffice-5.0.6.2-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 David Tardon 2016-06-09 05:29:37 UTC
*** Bug 1344040 has been marked as a duplicate of this bug. ***

Comment 7 Adri Verhoef 2016-06-09 09:22:30 UTC
$ rpm -q libreoffice-core
libreoffice-core-5.0.6.2-6.fc23.x86_64

Installed libreoffice-core-5.0.6.2-6.fc23.x86_64.
After opening existing files, oocalc and ooffice are still crashing after typing ESC in the search field.

Comment 8 Caolan McNamara 2016-06-09 10:42:12 UTC
bear with me, first fix didn't take

*** This bug has been marked as a duplicate of bug 1343766 ***

Comment 9 Adri Verhoef 2016-06-13 20:15:41 UTC
$ rpm -q libreoffice-core
libreoffice-core-5.0.6.2-7.fc23.x86_64

Problem solved.


Note You need to log in before you can comment on or make changes to this bug.