Bug 1342569 - "uReport data is invalid" when trying to report kernel crash
Summary: "uReport data is invalid" when trying to report kernel crash
Keywords:
Status: CLOSED DUPLICATE of bug 1481984
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-03 14:31 UTC by Milan Bouchet-Valat
Modified: 2019-01-24 15:28 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-20 20:47:27 UTC
Type: Bug


Attachments (Terms of Use)
Output of /usr/libexec/abrt-handle-event -vvv -e post-create . (31.76 KB, text/plain)
2016-06-07 08:55 UTC, Milan Bouchet-Valat
no flags Details
Output of reporter-ureport -vvv (30.27 KB, text/plain)
2017-08-17 09:15 UTC, Dan Dragomir
no flags Details

Description Milan Bouchet-Valat 2016-06-03 14:31:44 UTC
When trying to report kernel crashes, I always get the following error:

--- Running report_uReport ---
Le serveur a répondu par une erreur : « uReport data is invalid. »
reporter-ureport failed with exit code 1
(« report_uReport » a quitté avec code retour 1)

I'm not sure what information would be useful. If that helps, I've uploaded the dump at https://retrace.fedoraproject.org/faf/dumpdirs/new/vmcore-127.0.0.1-2016-06-03-13:00:25.tar.gz (package is kernel-core-4.5.4-200.fc23.x86_64).

Comment 1 Jakub Filak 2016-06-06 07:41:14 UTC
Thank you for the report. It would be best if you could run 'reporter-ureport -vvv' in the problem directory (/var/spool/abrt/vmcore...) and attach its output here.

Comment 2 Milan Bouchet-Valat 2016-06-06 15:16:41 UTC
Unfortunately, there isn't (or no longer is) a corresponding directory under /var/spool/abrt/vmcore/. The GUI tool doesn't list any reports either, which is weird since there are directories for other crashes.

Here's what I get if I do this from the only directory I could find -- but I guess that's not useful:
# cd /var/crash/127.0.0.1-2016-06-03-13\:00\:25/
# reporter-ureport -vvv
Configuration file '/etc/libreport/plugins/ureport.conf' contains no option
Unable to open './type': Aucun fichier ou dossier de ce type.

Comment 3 Jakub Filak 2016-06-07 07:39:36 UTC
Great, you still have the vmcore at place. Restart abrt-vmcore.service (systemctl restart abrt-vmcore.service) and a new directory in /var/spool/abrt should appear. Please, re-run the command in the new directory.

Comment 4 Milan Bouchet-Valat 2016-06-07 08:00:31 UTC
Cool. Now the directory is here, but I still get the same error:
# cd /var/spool/abrt/vmcore-127.0.0.1-2016-06-03-13\:00\:25/
# reporter-ureport -vvv
Configuration file '/etc/libreport/plugins/ureport.conf' contains no option
Unable to open './pkg_epoch': No such file or directory.

Comment 5 Jakub Filak 2016-06-07 08:40:34 UTC
Hmm, can you please run '/usr/libexec/abrt-handle-event -vvv -e post-create .' in that directory. It should either create the missing file or tell us why the missing file does not exist.

Comment 6 Jakub Filak 2016-06-07 08:46:34 UTC
Aha, the post-create EVENT does not create the missing file on purpose. The correct command you need to run (and we must add to our scripts) is "abrt-action-analyze-oops && abrt-action-save-package-data".

Comment 7 Milan Bouchet-Valat 2016-06-07 08:55:30 UTC
Created attachment 1165542 [details]
Output of /usr/libexec/abrt-handle-event -vvv -e post-create .

See the attached log. Doesn't seem to make a difference:

# reporter-ureport -vvvConfiguration file '/etc/libreport/plugins/ureport.conf' contains no option
Unable to open './pkg_epoch': No such file or directory
# abrt-action-analyze-oops && abrt-action-save-package-data
Can't open file 'executable': No such file or directory

Comment 8 Fedora End Of Life 2016-11-25 09:12:31 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 9 Fedora End Of Life 2016-12-20 20:47:27 UTC
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 10 Dan Dragomir 2017-08-17 09:15:40 UTC
Created attachment 1314603 [details]
Output of reporter-ureport -vvv

I am also experiencing this problem on Fedora 25. I attached the output of 'reporter-ureport -vvv' as mentioned in the previous comments.

Comment 11 Julius Milan 2017-08-17 10:18:06 UTC

*** This bug has been marked as a duplicate of bug 1481984 ***


Note You need to log in before you can comment on or make changes to this bug.