Bug 134260 - system-config-printer ignores the Imageable Area in the Queue options
system-config-printer ignores the Imageable Area in the Queue options
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 13:20 EDT by JM
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 05:56:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description JM 2004-09-30 13:20:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040924
Firefox/0.10

Description of problem:
system-config-printer ignores the Imageable Area in the Queue options,
I tried to change the Imageable Area for a HP-LaserJet but the values
inside the PPD (*ImageableArea) start always from (for A4) 0 0 to 595
842, when I change the *ImageableArea in the PPD manually then cups
prints the pages correct. Try for example "kedit" and print a simple
document, all lines on the left start to early because the
*ImageableArea in the PPD for the left side is 0 no matter what you
add in the system-config-printer tool.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.98-1

How reproducible:
Always

Steps to Reproduce:
1. Change the Imageable Area with system-config-printer
2. Start "kedit" and print a document

    

Actual Results:  You will see that all lines start to early on the
left side because system-config-printer ignores the Imageable Area in
the Queue options.

Expected Results:  system-config-printer should set the Imageable Area
in the PPD file correct.

Additional info:
Comment 1 Tim Waugh 2004-12-07 09:55:19 EST
I think this is caused by foomatic already providing margins for that model. 
Needs a way of knowing when to override those.
Comment 2 JM 2005-02-02 07:04:10 EST
system-config-printer in version 0.6.116.1-1 for FC3 has still the
problem, this way system-config-printer is of limited use.
Comment 3 Tim Waugh 2005-05-15 06:51:13 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.