Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1342629 - seeing rabbitmq is reporting heartbeat timeout to some nodes [NEEDINFO]
Summary: seeing rabbitmq is reporting heartbeat timeout to some nodes
Keywords:
Status: CLOSED DUPLICATE of bug 1295896
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Peter Lemenkov
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-03 17:40 UTC by bigswitch
Modified: 2016-07-21 21:21 UTC (History)
5 users (show)

Fixed In Version: python-oslo-messaging-1.8.3-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-21 21:21:17 UTC
Target Upstream Version:
plemenko: needinfo? (rhosp-bugs-internal)


Attachments (Terms of Use)

Description bigswitch 2016-06-03 17:40:57 UTC
Description of problem:
Seen in Dell scale setup with 299 compute nodes and three controller. notice on rabbitmq log that it is reporting heartbeat timeout to some nodes.
The network is stable at that time and no network event is going on. want to know if this is acceptable and if there is any impact to the overcloud

=INFO REPORT==== 26-May-2016::00:18:28 ===
--
=ERROR REPORT==== 26-May-2016::00:18:44 ===
closing AMQP connection <0.14519.1> (172.17.1.68:41262 -> 172.17.0.14:5672):
{heartbeat_timeout,running}

=INFO REPORT==== 26-May-2016::00:18:45 ===
--
=ERROR REPORT==== 26-May-2016::00:19:09 ===
closing AMQP connection <0.384.0> (172.17.0.172:58136 -> 172.17.0.14:5672):
{heartbeat_timeout,running}

=ERROR REPORT==== 26-May-2016::00:19:09 ===
closing AMQP connection <0.478.0> (172.17.0.86:52691 -> 172.17.0.14:5672):
{heartbeat_timeout,running}

=ERROR REPORT==== 26-May-2016::00:19:09 ===
closing AMQP connection <0.462.0> (172.17.0.86:52690 -> 172.17.0.14:5672):
{heartbeat_timeout,running}

Version-Release number of selected component (if applicable):
RHOSP 8

Comment 2 Peter Lemenkov 2016-06-20 14:28:34 UTC
(In reply to bigswitch from comment #0)
> Description of problem:
> Seen in Dell scale setup with 299 compute nodes and three controller. notice
> on rabbitmq log that it is reporting heartbeat timeout to some nodes.
> The network is stable at that time and no network event is going on. want to
> know if this is acceptable and if there is any impact to the overcloud
> 
> =INFO REPORT==== 26-May-2016::00:18:28 ===
> --
> =ERROR REPORT==== 26-May-2016::00:18:44 ===
> closing AMQP connection <0.14519.1> (172.17.1.68:41262 -> 172.17.0.14:5672):
> {heartbeat_timeout,running}
> 
> =INFO REPORT==== 26-May-2016::00:18:45 ===
> --
> =ERROR REPORT==== 26-May-2016::00:19:09 ===
> closing AMQP connection <0.384.0> (172.17.0.172:58136 -> 172.17.0.14:5672):
> {heartbeat_timeout,running}
> 
> =ERROR REPORT==== 26-May-2016::00:19:09 ===
> closing AMQP connection <0.478.0> (172.17.0.86:52691 -> 172.17.0.14:5672):
> {heartbeat_timeout,running}
> 
> =ERROR REPORT==== 26-May-2016::00:19:09 ===
> closing AMQP connection <0.462.0> (172.17.0.86:52690 -> 172.17.0.14:5672):
> {heartbeat_timeout,running}
> 
> Version-Release number of selected component (if applicable):
> RHOSP 8

What's the version of python-oslo-messaging ? I believe it might be the same as bug 1295896.

Comment 3 Peter Lemenkov 2016-06-29 15:35:31 UTC
(In reply to bigswitch from comment #0)

How's it going? Do you still see these issues?

Comment 4 Peter Lemenkov 2016-07-21 21:21:17 UTC
Closing this as a duplicate of bug 1295896.

*** This bug has been marked as a duplicate of bug 1295896 ***


Note You need to log in before you can comment on or make changes to this bug.