Bug 134271 - udev complains if no files are in /etc/udev/devices
udev complains if no files are in /etc/udev/devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-30 15:13 EDT by Bernard Johnson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: udev-032-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 04:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2004-09-30 15:13:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
If there are no files in /etc/udev/devices, start_udev complains on
bootup:




Version-Release number of selected component (if applicable):
udev-032-5

How reproducible:
Always

Steps to Reproduce:
1. boot system with no files in /etc/udev/devices
2.
3.
    

Actual Results:                  Welcome to Fedora Core
                Press 'I' to enter interactive startup.
Making extra nodes:  cp: cannot stat `/etc/udev/devices/*': No such
file or directory
[FAILED]

Expected Results:  no complaint message

Additional info:
Comment 1 TGS 2004-10-01 03:49:15 EDT
Same error here.
Comment 2 TGS 2004-10-01 03:53:29 EDT
I should add that the system hangs at this point.

Just updated my system to the latest development as of 3 AM EST, and 
cannot
boot. 

Error follows:

Press 'I' to enter interactive startup.

Making extra nodes: cp: cannot stat '/etc/udev/devices/*': No such 
file or
directory
                                                     [FAILED]
Starting udev:                                       [  OK  ]
Initializing hardware... storage network audio done [  OK  ]
Configuring kernel parameters:

then nothing, since it is frozen.
Comment 3 Harald Hoyer 2004-10-01 04:22:19 EDT
seems like /etc/sysctl.conf is b0rken or /proc is not mounted...
the "cp" error does not harm... really...
Comment 4 TGS 2004-10-01 08:20:02 EDT
Update: if I remove the rhgb option from the grub kernel options, I 
can boot.

Note You need to log in before you can comment on or make changes to this bug.