Bug 1342739 - [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by SIGTRAP
Summary: [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by SIGTRAP
Status: CLOSED DUPLICATE of bug 1350184
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:eb8620f537b40e19afe58717afc...
Keywords:
: 1349190 1350543 1353356 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-04 13:43 UTC by Yuriy
Modified: 2016-07-06 21:55 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-01 18:11:42 UTC


Attachments (Terms of Use)
File: backtrace (62.44 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: cgroup (240 bytes, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: core_backtrace (16.97 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: dso_list (24.94 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: environ (1.08 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: limits (1.29 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: maps (99.53 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: mountinfo (3.75 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: namespaces (102 bytes, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: open_fds (4.52 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: proc_pid_status (1.08 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details
File: var_log_messages (1.02 KB, text/plain)
2016-06-04 13:43 UTC, Yuriy
no flags Details

Description Yuriy 2016-06-04 13:43:11 UTC
Description of problem:
This happend with nvidia driver 364.19

Version-Release number of selected component:
gnome-shell-3.20.2-1.fc24

Additional info:
reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _g_log_abort
executable:     /usr/bin/gnome-shell
global_pid:     1476
kernel:         4.5.6-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reproducible:   The problem is reproducible
runlevel:       N 5
type:           CCpp
uid:            42

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _g_log_abort at gmessages.c:325
 #3 _cogl_offscreen_gl_allocate at driver/gl/cogl-framebuffer-gl.c:953
 #4 cogl_framebuffer_allocate at cogl-framebuffer.c:798
 #5 _cogl_framebuffer_gl_flush_state at driver/gl/cogl-framebuffer-gl.c:390
 #6 cogl_framebuffer_clear4f at cogl-framebuffer.c:385
 #7 st_theme_node_prerender_shadow at st/st-theme-node-drawing.c:2277
 #8 st_theme_node_render_resources at st/st-theme-node-drawing.c:1524
 #9 st_theme_node_paint at st/st-theme-node-drawing.c:2521
 #10 st_widget_paint_background at st/st-widget.c:457
 #11 st_widget_paint at st/st-widget.c:467

Comment 1 Yuriy 2016-06-04 13:43:17 UTC
Created attachment 1164775 [details]
File: backtrace

Comment 2 Yuriy 2016-06-04 13:43:19 UTC
Created attachment 1164776 [details]
File: cgroup

Comment 3 Yuriy 2016-06-04 13:43:20 UTC
Created attachment 1164777 [details]
File: core_backtrace

Comment 4 Yuriy 2016-06-04 13:43:22 UTC
Created attachment 1164778 [details]
File: dso_list

Comment 5 Yuriy 2016-06-04 13:43:23 UTC
Created attachment 1164779 [details]
File: environ

Comment 6 Yuriy 2016-06-04 13:43:25 UTC
Created attachment 1164780 [details]
File: limits

Comment 7 Yuriy 2016-06-04 13:43:27 UTC
Created attachment 1164781 [details]
File: maps

Comment 8 Yuriy 2016-06-04 13:43:29 UTC
Created attachment 1164782 [details]
File: mountinfo

Comment 9 Yuriy 2016-06-04 13:43:30 UTC
Created attachment 1164783 [details]
File: namespaces

Comment 10 Yuriy 2016-06-04 13:43:31 UTC
Created attachment 1164784 [details]
File: open_fds

Comment 11 Yuriy 2016-06-04 13:43:33 UTC
Created attachment 1164785 [details]
File: proc_pid_status

Comment 12 Yuriy 2016-06-04 13:43:34 UTC
Created attachment 1164786 [details]
File: var_log_messages

Comment 13 kartochka22 2016-06-17 11:02:16 UTC
nvidia driver 367.27

Comment 14 Martino 2016-06-22 22:09:22 UTC
*** Bug 1349190 has been marked as a duplicate of this bug. ***

Comment 15 yuriireutov 2016-06-24 00:36:41 UTC
Similar problem has been detected:

Gnome crashes with nvidia proprietary driver.
Tested on http://negativo17.org/nvidia-driver/ kmod and nvidia official http://www.nvidia.ru/download/driverResults.aspx/104321/
SELinux policy modified.
ausearch -c 'gnome-shell' --raw | 
emodule -X 300 -i my-gnomeshell.pp
nouveau works fine.

reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _g_log_abort
executable:     /usr/bin/gnome-shell
global_pid:     1377
kernel:         4.5.7-300.fc24.x86_64
package:        gnome-shell-3.20.2-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGTRAP
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            42

Comment 16 yuriireutov 2016-06-24 03:45:50 UTC
Similar problem has been detected:

SELinux alert on crash looks like this:

SELinux is preventing gnome-shell from execute access on the file 2F7661722F6C69622F67646D2F2335373638353031202864656C6574656429.

*****  Plugin catchall (100. confidence) suggests   **************************

If вы считаете, что gnome-shell следует разрешить доступ execute к 2F7661722F6C69622F67646D2F2335373638353031202864656C6574656429 file по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
allow this access for now by executing:
# ausearch -c 'gnome-shell' --raw | audit2allow -M my-gnomeshell
# semodule -X 300 -i my-gnomeshell.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:xdm_var_lib_t:s0
Target Objects                2F7661722F6C69622F67646D2F233537363835303120286465
                              6C6574656429 [ file ]
Source                        gnome-shell
Source Path                   gnome-shell
Port                          <Unknown>
Host                          COMP
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-190.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     COMP
Platform                      Linux COMP 4.5.5-300.fc24.x86_64 #1 SMP Thu May 19
                              13:05:32 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-06-24 06:26:15 MSK
Last Seen                     2016-06-24 06:31:41 MSK
Local ID                      3c431f0d-183f-4f8d-81cd-334634a5c81f

Raw Audit Messages
type=AVC msg=audit(1466739101.123:364): avc:  denied  { execute } for  pid=2999 comm="gnome-shell" path=2F7661722F6C69622F67646D2F2335373638353031202864656C6574656429 dev="sda3" ino=5768501 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file permissive=1


Hash: gnome-shell,xdm_t,xdm_var_lib_t,file,execute

SElinux in permissive mode this time.

SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          permissive
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      30

reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _g_log_abort
executable:     /usr/bin/gnome-shell
global_pid:     1383
kernel:         4.5.5-300.fc24.x86_64
package:        gnome-shell-3.20.2-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGTRAP
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            42

Comment 17 Joran Martinière 2016-06-25 20:32:09 UTC
Similar problem has been detected:

It happens 5 minutes after logging in.

reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _g_log_abort
executable:     /usr/bin/gnome-shell
global_pid:     1989
kernel:         4.5.7-300.fc24.x86_64
package:        gnome-shell-3.20.2-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGTRAP
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 18 Tutul 2016-06-27 00:17:44 UTC
Similar problem has been detected:

Just do an upgrade from fedora 23 to fedora 24 and gnome crash (~3-5 minutes after boot). 
See these with journactl (during boot) : jun 27 01:46:03 TUTUL-SUPERTUX gnome-session-binary[2149]: Unrecoverable failure in required component org.gnome.Shell.desktop
Recently I update my UEFI (MSI X99A-RAIDER) to p40 and Secure boot is force-enabled and option to disable it disapear (but Fedora 23 was fine on it).

reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _g_log_abort
executable:     /usr/bin/gnome-shell
global_pid:     25566
kernel:         4.5.7-300.fc24.x86_64
package:        gnome-shell-3.20.2-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGTRAP
reproducible:   The problem occurs regularly
runlevel:       N 5
type:           CCpp
uid:            42

Comment 19 Martino 2016-06-27 17:57:00 UTC
*** Bug 1350543 has been marked as a duplicate of this bug. ***

Comment 20 7oxicshadow 2016-06-28 09:47:07 UTC
I believe this is related to the following issue:

https://bugzilla.gnome.org/show_bug.cgi?id=764898
https://bugs.archlinux.org/task/48772

It has been fixed upstream (gnome-shell-3.20.3).

If this is confirmed to be the issue, how long does it typically take to get it into the Fedora 24 Repos? There are a number of users affected, especially those using the NVIDIA proprietary drivers.

Comment 21 Anton Barsukov 2016-06-29 10:14:56 UTC
Similar problem has been detected:

gdm.service just crashed and I have to manually switch tty to back to my desktop environment

reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _g_log_abort
executable:     /usr/bin/gnome-shell
global_pid:     1961
kernel:         4.5.7-300.fc24.x86_64
package:        gnome-shell-3.20.2-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGTRAP
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            42

Comment 22 Joseph D. Wagner 2016-07-01 15:48:53 UTC
I can reproduce the problem 100% (at least as described by #21, assuming this is the same problem).

1. Boot the system.  It happens to me only once per boot.
2. Login.  It doesn't happen at the logon screen, only after a user is logged in.
3. Wait almost exactly 5 minutes.  Doesn't matter if you do anything or just sit there.

Comment 23 Florian Müllner 2016-07-01 18:11:42 UTC

*** This bug has been marked as a duplicate of bug 1350184 ***

Comment 24 Martino 2016-07-06 21:55:25 UTC
*** Bug 1353356 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.