Bug 134274 - missing dependency for alchemist
Summary: missing dependency for alchemist
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard: RHEL3U7NAK
Keywords:
Depends On:
Blocks: 189875
TreeView+ depends on / blocked
 
Reported: 2004-09-30 20:08 UTC by Bert de Bruijn
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 08:34:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bert de Bruijn 2004-09-30 20:08:16 UTC
Description of problem:
Postinstall script in redhat-config-print might fail because it needs
alchemist, which is not required.

postinstall scriptlet (using /bin/sh):
# The gimp-print driver changed its name, so update the configuration.
/usr/share/printconf/util/updateconf.py


Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.11-1

How reproducible:
install redhat-config-printer without alchemist already installed. 

Steps to Reproduce:
1. rpm -e alchemist redhat-config-printer
2. rpm -i redhat-config-printer-0.6.47.11-1.i386.rpm

  
Actual results:
Traceback (most recent call last):
 File "/usr/share/printconf/util/updateconf.py", line 29, in ?
  import printconf_conf as conf
 File "/usr/share/printconf/util/printconf_conf.py", line 580, in?
  from pyalchemist import *
ImportError: No module named pyalchemist

Expected results:
no output

Comment 1 Tim Waugh 2004-10-11 11:28:49 UTC
Thanks.  Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.