Bug 1342748 - monitor not recognised on X11 intel drivers
Summary: monitor not recognised on X11 intel drivers
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel   
(Show other bugs)
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-04 17:26 UTC by Albert Szostkiewicz
Modified: 2017-08-01 12:15 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-drv-intel-2.99.917-26.20160929.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:15:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from centos kernel (36.48 KB, text/plain)
2016-06-05 20:13 UTC, Albert Szostkiewicz
no flags Details
log from kernel-ml (41.89 KB, text/plain)
2016-06-05 20:13 UTC, Albert Szostkiewicz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1905 normal SHIPPED_LIVE Xorg X11 server and drivers bug fix and enhancement update 2017-08-01 16:03:51 UTC
CentOS 0010968 None None None 2016-06-06 01:32 UTC

Description Albert Szostkiewicz 2016-06-04 17:26:58 UTC
Description of problem:

Internal monitor of DELL XPS13 9350 is not recognized with latest available X11-drv-intel (299.217-8.20150615)
Causing lack of brightness control, blank screen after suspend, no possibility to put monitor to sleep in power management etc.
Using Centos7

Version-Release number of selected component (if applicable):

DELL XPS13 9350 (2016)
391-BCHU, 13.3 inch FHD AG (1920 x 1080) InfinityEdge display, Silver
X11-drv-intel (299.217-8.20150615) 64bit 
CentOS Linux release 7.2.1511 (Core)

How reproducible:
Always


Steps to Reproduce:
1.Install distro, x11-drv-lnx comes with it.
2.
3.

Actual results:
Monitor:Unknown
Black screen after suspend, unable to awake
unable to control brightness
unable to put screen to sleep in power management

Expected results:
Everything working as it should


Additional info:

Comment 2 Albert Szostkiewicz 2016-06-05 19:31:22 UTC
Tested CentOS kernel 3.10.0-327.18.2.el7.x86_64

>xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080     77.00*


Kernel kernel-ml from elrepo
4.6.1-1.el7.elrepo.x86_64
Recognizes monitor, but unfortunately breaks other things

> xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   1920x1080     59.93*+
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1280x960      60.00  
   1368x768      60.00  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   640x360       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Comment 3 Albert Szostkiewicz 2016-06-05 20:13 UTC
Created attachment 1164951 [details]
log from centos kernel

Comment 4 Albert Szostkiewicz 2016-06-05 20:13 UTC
Created attachment 1164952 [details]
log from kernel-ml

Comment 5 Adam Jackson 2017-01-31 20:00:26 UTC
This is just skylake support being absent from 7.2. Should be fixed in 7.4.

Comment 8 errata-xmlrpc 2017-08-01 12:15:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1905


Note You need to log in before you can comment on or make changes to this bug.