Bug 1342787 - [RFE] OpenSCAP results --> Severity should be differentiated with adequate colors
Summary: [RFE] OpenSCAP results --> Severity should be differentiated with adequate co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Eric Winchell
QA Contact: Pavel Zagalsky
URL:
Whiteboard:
Depends On:
Blocks: 1377417
TreeView+ depends on / blocked
 
Reported: 2016-06-05 10:17 UTC by Pavel Zagalsky
Modified: 2017-08-30 01:36 UTC (History)
7 users (show)

Fixed In Version: 5.7.0.2
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1377417 (view as bug list)
Environment:
Last Closed: 2017-01-11 20:27:50 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)
OpenSCAP Results (113.22 KB, image/png)
2016-06-05 10:17 UTC, Pavel Zagalsky
no flags Details

Description Pavel Zagalsky 2016-06-05 10:17:40 UTC
Created attachment 1164864 [details]
OpenSCAP Results

Description of problem:
After running compliance test on an image the OpenSCAP Results page shows results without any color differentiation regarding the Severity of the result.

Expected results:
The columns should be colored similarly to what we see in the OpenSCAP HTML results

Additional info:
Screenshot attached

Comment 5 CFME Bot 2016-09-19 15:26:04 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/bc6dd971483c8f157b59b92fc59be0f75f133aa1

commit bc6dd971483c8f157b59b92fc59be0f75f133aa1
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Thu Sep 15 10:15:39 2016 -0400
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Mon Sep 19 08:59:04 2016 -0400

    Update openSCAP results styling
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1342787

 app/assets/stylesheets/patternfly_overrides.scss |  1 -
 app/controllers/application_controller.rb        | 28 +++++++++++++++++++++++-
 app/views/layouts/_list_grid.html.haml           |  3 +++
 3 files changed, 30 insertions(+), 2 deletions(-)

Comment 7 CFME Bot 2016-09-23 17:45:59 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/28d55c229ee70ee74e00661109824ecad8be8b13

commit 28d55c229ee70ee74e00661109824ecad8be8b13
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Wed Sep 21 16:02:15 2016 -0400
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Thu Sep 22 11:09:45 2016 -0400

    Update openSCAP results styling
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1342787

 app/assets/stylesheets/main.scss                 |  1 +
 app/assets/stylesheets/patternfly_overrides.scss | 10 ++++++++++
 app/controllers/application_controller.rb        | 12 ++++++------
 3 files changed, 17 insertions(+), 6 deletions(-)

Comment 8 CFME Bot 2016-09-29 13:26:26 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/e4d95168bb6cfe1e7b400d64cfd9911eb7f15980

commit e4d95168bb6cfe1e7b400d64cfd9911eb7f15980
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Wed Sep 28 10:30:45 2016 -0400
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Wed Sep 28 10:30:45 2016 -0400

    Summary Screen styling updates
    
    This bug was caused by the following PR: #11288
    
    Issue #11388
    https://bugzilla.redhat.com/show_bug.cgi?id=1342787
    Depends on: #11288 and #11420

 app/assets/stylesheets/patternfly_overrides.scss |  1 +
 app/views/vm_common/_config.html.haml            | 12 ++++++------
 2 files changed, 7 insertions(+), 6 deletions(-)

Comment 9 Pavel Zagalsky 2016-11-14 11:50:04 UTC
Cannot test this atm, https://bugzilla.redhat.com/show_bug.cgi?id=1382326 is blocking me

Comment 10 Pavel Zagalsky 2016-11-28 15:20:00 UTC
Verified


Note You need to log in before you can comment on or make changes to this bug.