Bug 1342828 - [X11 on Wayland] LibreOffice Toolbars are jumping around while being moved
Summary: [X11 on Wayland] LibreOffice Toolbars are jumping around while being moved
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1342827 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-06-05 16:37 UTC by Christian Stadelmann
Modified: 2016-11-19 21:16 UTC (History)
5 users (show)

Fixed In Version: libreoffice-5.2.3.3-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-19 21:16:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 768098 None None None 2016-06-28 08:25:29 UTC
GNOME Bugzilla 768128 None None None 2016-06-28 08:24:52 UTC

Description Christian Stadelmann 2016-06-05 16:37:35 UTC
Description of problem:
Once a toolbar is detached in LibreOffice running on X11 backend in a Gnome+Wayland session, the toolbar jumping around when being dragged

Version-Release number of selected component (if applicable):
libreoffice-5.1.3.2-7.fc24.x86_64 with gtk3-3.20.6-1.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open any LibreOffice component (Writer, Calc, Base, …)
2. Detach any toolbar by dragging it
3. Drag the toolbar around

Actual results:
While being dragged, the toolbar is jumping around.

Expected results:
No jumping, toolbar should just follow mouse movements.

Additional info:
This issue is only present when running LibreOffice with Gtk+ 3.x with x11 Gdk backend inside a Gnome+wayland.
On weston, the detached toolbar can't be dragged at all.
I'm not sure this is a LibreOffice issue, it could also be somewhere else (e.g. mutter). You probably know better so please feel free to reassign.

Comment 1 Caolan McNamara 2016-06-06 16:46:47 UTC
*** Bug 1342827 has been marked as a duplicate of this bug. ***

Comment 2 Christian Stadelmann 2016-06-27 08:43:49 UTC
As a result of this bug, there is no intuitive (simple) way to reattach a toolbar.

To at least get those toolbars reattached, you may want to double-right-click on a toolbar header. I don't know why that works, but it does.

Comment 3 Caolan McNamara 2016-06-27 08:58:50 UTC
I can drag around under X and under wayland without any particular problem that I can see. Can't dock under wayland though

Comment 4 Caolan McNamara 2016-06-27 14:14:59 UTC
The jumpiness seems to be because we're using both gtk_window_begin_move_drag and explicitly trying to set the position so they fight it out. Under wayland explicit positioning doesn't work at all, under x11 gtk_window_begin_move_drag isn't working with GDK_WINDOW_TYPE_HINT_TOOLBAR set for some reason

https://bugzilla.gnome.org/show_bug.cgi?id=768098 for the GDK_WINDOW_TYPE_HINT_TOOLBAR problem to see if anyone knows why that is

Comment 5 Christian Stadelmann 2016-06-27 15:16:45 UTC
(In reply to Caolan McNamara from comment #3)
> I can drag around under X and under wayland without any particular problem
> that I can see. Can't dock under wayland though

You have to exactly follow the steps (I was a bit imprecise above):

Steps to Reproduce:
1. Open any LibreOffice component (Writer, Calc, Base, …)
2. Detach any toolbar by dragging it. Release the mouse button.
3. Drag the toolbar around

Before releasing the mouse button, dragging looks good. Only after releasing it and grabbing it again it jumps around.

Comment 6 Caolan McNamara 2016-06-28 08:24:53 UTC
When it comes to docking I don't seem to get anything under wayland which can be used to detect that the window has been dragged over a docking point https://bugzilla.gnome.org/show_bug.cgi?id=768128

Comment 7 Jan Kurik 2016-07-26 04:08:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 8 Christian Stadelmann 2016-09-19 11:57:50 UTC
This issue is not specific to the Gtk+ 3 backend but also happens with SAL_USE_VCLPLUGIN=gen in environment.

Comment 9 Caolan McNamara 2016-11-10 10:42:18 UTC
seems to me that moveable toplevel dockable toolbars are just going to be a pain in the new world order and its futile to fight the tide

Comment 10 Fedora Update System 2016-11-11 08:59:38 UTC
libreoffice-5.2.3.3-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0438bf95e5

Comment 11 Fedora Update System 2016-11-11 16:58:30 UTC
libreoffice-5.2.3.3-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0438bf95e5

Comment 12 Fedora Update System 2016-11-19 21:16:33 UTC
libreoffice-5.2.3.3-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.