Bug 134286 - validating parser in sax fails to call endElement
Summary: validating parser in sax fails to call endElement
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: PyXML   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-30 22:17 UTC by Kevin J. Miller
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 22:01:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test script, input and output (1.11 KB, application/octet-stream)
2004-09-30 22:19 UTC, Kevin J. Miller
no flags Details

Description Kevin J. Miller 2004-09-30 22:17:49 UTC
Description of problem:
In version 0.7.1 of PyXML, the validating parser in sax does not
invoke the endElement callback.  The non-validating parser work
correctly.  The problem is fixed in version 0.8.3.

Version-Release number of selected component (if applicable):
0.7.1

How reproducible:
Always.

Steps to Reproduce:
Run: ./py_xml_demo_1 test.xml
from attached tarball
  
Actual results:
See out1-0.7.1

Expected results:
See out1-0.8.3

Additional info:

Comment 1 Kevin J. Miller 2004-09-30 22:19:58 UTC
Created attachment 104605 [details]
test script, input and output

Comment 2 Florian La Roche 2005-09-28 22:01:20 UTC
This is fixed in newer releases, so closing this bug here.



Note You need to log in before you can comment on or make changes to this bug.