Bug 1342916 - Could not read interface p2p-dev-wlp3s0 flags: No such device
Summary: Could not read interface p2p-dev-wlp3s0 flags: No such device
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-06 06:27 UTC by Jan Synacek
Modified: 2017-08-08 14:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 14:45:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Synacek 2016-06-06 06:27:45 UTC
Description of problem:
I'm getting the following error in the logs on boot:

Jun 06 07:28:18 jsynacek-ntb wpa_supplicant[1065]: Could not read interface p2p-dev-wlp3s0 flags: No such device

No idea where the device name is coming from.

$ ip link show wlp3s0
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 28:b2:bd:b8:e5:f2 brd ff:ff:ff:ff:ff:ff


Version-Release number of selected component (if applicable):
wpa_supplicant-2.5-5.fc24.x86_64
kernel-4.5.5-300.fc24.x86_64


Steps to Reproduce:
1. Boot the latest F24.
2. Check the system logs.


Actual results:
Error in the logs.


Expected results:
No errors in the logs.


Additional info:
The error message seems to have no effect on proper function of the wireless device.

Comment 1 Jan Synacek 2016-06-06 06:30:14 UTC
Some additional info:

$ lspci | grep Wireless
03:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)

$ rpm -q iwl7260-firmware
iwl7260-firmware-25.30.13.0-65.fc24.noarch

Comment 2 Jan Synacek 2016-08-05 13:10:44 UTC
The fix for this is trivial:

--- /etc/wpa_supplicant/wpa_supplicant.conf     2016-02-05 11:42:44.000000000 +0100
+++ /etc/wpa_supplicant/wpa_supplicant.conf.new 2016-08-05 15:09:25.218795270 +0200
@@ -1,3 +1,4 @@
 ctrl_interface=/var/run/wpa_supplicant
 ctrl_interface_group=wheel
+p2p_disabled=1

Comment 3 Yu Watanabe 2016-10-13 05:32:03 UTC
I also use Intel Wifi 7260 and found the same error message.
I've tried 'p2p_disabled=1', but it does not change the situation.

Comment 4 Dmitry Minsky 2017-01-08 19:59:33 UTC
Same here on F25 with kernel 4.8.15-300.fc25.x86_64
Even with p2p_disabled=1 in /etc/wpa_supplicant/wpa_supplicant.conf

wpa_supplicant[1113]: p2p-dev-wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
wpa_supplicant[1113]: p2p-dev-wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
wpa_supplicant[1113]: Could not read interface p2p-dev-wlp2s0 flags: No such device
wpa_supplicant[1113]: Successfully initialized wpa_supplicant

Comment 5 Fedora End Of Life 2017-07-25 21:01:02 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 6 Fedora End Of Life 2017-08-08 14:45:59 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.