Bug 134293 - _gnome_vfs_drive_from_corba segfaults
_gnome_vfs_drive_from_corba segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-30 20:43 EDT by Bill Nottingham
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 10:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-09-30 20:43:56 EDT
Description of problem:

*boom*

Version-Release number of selected component (if applicable):

2.8.0-1

How reproducible:

Every time
Steps to Reproduce:
1. Open document
2. Choose 'Print'
3. Chose 'Generic Postscript', 'File', 'Save to output.ps'
  
Actual results:

*boom*

Expected results:

Well, not that.

Additional info:

#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xf6e123eb in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x07bdef50 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0xf6f3b690 in _gnome_vfs_drive_from_corba ()
   from /usr/lib/libgnomevfs-2.so.0
#5  0xf6f54ef2 in gnome_vfs_volume_monitor_client_get_type ()
   from /usr/lib/libgnomevfs-2.so.0
#6  0xf6f550a4 in gnome_vfs_volume_monitor_client_get_type ()
   from /usr/lib/libgnomevfs-2.so.0
#7  0x00ce32cc in g_type_create_instance () from
/usr/lib/libgobject-2.0.so.0
#8  0x00cca5a1 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#9  0x00cc983f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#10 0x00cca459 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#11 0x00cca578 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#12 0xf6f55889 in _gnome_vfs_get_volume_monitor_internal ()
   from /usr/lib/libgnomevfs-2.so.0
#13 0xf6f558e0 in gnome_vfs_get_volume_monitor ()
   from /usr/lib/libgnomevfs-2.so.0
#14 0xf4f9b1cb in gtk_file_system_gnome_vfs_new ()
   from /usr/lib/gtk-2.0/2.4.0/filesystems/libgnome-vfs.so
#15 0x00ce32cc in g_type_create_instance () from
/usr/lib/libgobject-2.0.so.0
#16 0x00cca5a1 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#17 0x00cc983f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#18 0x00cca459 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#19 0x00cca578 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#20 0xf4f9afce in gtk_file_system_gnome_vfs_new ()
   from /usr/lib/gtk-2.0/2.4.0/filesystems/libgnome-vfs.so
#21 0xf4f9e20f in fs_module_create ()
   from /usr/lib/gtk-2.0/2.4.0/filesystems/libgnome-vfs.so
#22 0x002304ec in gtk_file_system_module_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#23 0x002305d1 in gtk_file_system_module_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#24 0x00222c49 in shortcuts_model_filter_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#25 0x00cca777 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#26 0x00222ca3 in shortcuts_model_filter_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#27 0x00cc983f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#28 0x00cca386 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#29 0x00cca578 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#30 0x00224f73 in shortcuts_model_filter_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#31 0x0022627d in gtk_file_chooser_widget_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#32 0x00cc983f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#33 0x00cca459 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#34 0x00cca578 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#35 0x0021a8ee in gtk_file_chooser_dialog_get_type ()
   from /usr/lib/libgtk-x11-2.0.so.0
#36 0x00cc983f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#37 0x00cca386 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#38 0x00cca578 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#39 0x07c95eff in gpa_transport_selector_get_type ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#40 0x00cde0ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#41 0x00cc6347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#42 0x00cdb94e in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#43 0x00cdd9bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#44 0x00cddc5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#45 0x001b62a4 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#46 0x001b7d24 in gtk_button_get_alignment () from
/usr/lib/libgtk-x11-2.0.so.0
#47 0x00cde0ae in g_cclosure_marshal_VOID__VOID ()
#48 0x00cc66b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#49 0x00cc6347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#50 0x00cdb616 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#51 0x00cdd9bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#52 0x00cddc5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#53 0x001b61ec in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#54 0x001b7297 in gtk_button_set_relief () from
/usr/lib/libgtk-x11-2.0.so.0
#55 0x0026dd87 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#56 0x00cc66b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#57 0x00cc6347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#58 0x00cdc576 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#59 0x00cdd613 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#60 0x00cddc5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#61 0x00361865 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#62 0x0026c04b in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#63 0x0026c350 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#64 0x00db8092 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#65 0x00c104fb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#66 0x00c11f82 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#67 0x00c1222f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#68 0x00201ab5 in gtk_dialog_run () from /usr/lib/libgtk-x11-2.0.so.0
#69 0x00000000 in ?? ()
Comment 1 Bill Nottingham 2004-09-30 21:01:30 EDT
Actually, this pretty much happens on any invocation of the file
chooser. ('open' in the menu, for instance.)
Comment 2 Matthias Clasen 2004-10-01 01:24:28 EDT
That doesn't happen for me. Both opening pdfs and printing to
postscript work fine with gpdf-2.8.0-1 and gtk2-2.4.10-5
Comment 3 Alexander Larsson 2004-10-01 05:23:46 EDT
This is likely to be due to changes in the internal gnome-vfs corba
interface. The lib and daemon changed, but an old daemon is still running.
Comment 4 Dan Williams 2004-10-01 07:46:20 EDT
over to gnome-vfs2 then, it was seen in Evolution yesterday too by
Walters.
Comment 5 Alexander Larsson 2004-10-01 10:19:39 EDT
I'm not sure what can be done about it. Killall gnome-vfs-daemon or
log out/in will fix it.
Comment 6 Alexander Larsson 2004-10-01 10:34:21 EDT
I'll just close it RAWHIDE...
Comment 7 Bill Nottingham 2004-10-01 12:03:51 EDT
Do we want to do the killall on upgrade in %post?
Comment 8 Alexander Larsson 2004-10-04 03:34:45 EDT
Possibly. Although that could cause minor irritation in most cases
where the interface didn't change.

Gnome-vfs does handle the daemon dying properly, and restarts it.
However some things, like authenticated connections, gets lost when
the daemon dies.

Hmm, actually killall might not help. You need to restart the apps
that use the library too. :(
Comment 9 Bill Nottingham 2004-10-04 11:15:23 EDT
Well... if this interface will never change in a stable gnome series
(2.8.x, etc.), then I suppose it's not really an issue.

If it's going to change at every new 2.8.x, then it's more of a problem.
Comment 10 Alexander Larsson 2004-10-04 12:19:39 EDT
Nah. It'll be stable.

Note You need to log in before you can comment on or make changes to this bug.