Bug 134294 - yum fails to update on fc3test2
yum fails to update on fc3test2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 20:52 EDT by Thierry moisan
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 14:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output of the bug (658 bytes, text/plain)
2004-09-30 20:53 EDT, Thierry moisan
no flags Details

  None (edit)
Description Thierry moisan 2004-09-30 20:52:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
I updated yum recently to stop having this bug :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133274 , but when
I try to simply do yum update I get a error message. Will post the
output very soon. Before getting this I did "yum clean headers".




Version-Release number of selected component (if applicable):
yum-2.1.4-1

How reproducible:
Always

Steps to Reproduce:
1. yum clean headers
2. yum update

    

Actual Results:  Error Message

Expected Results:  No error and updating succesfully
Comment 1 Thierry moisan 2004-09-30 20:53:44 EDT
Created attachment 104610 [details]
The output of the bug
Comment 2 Seth Vidal 2004-10-01 01:51:27 EDT
You've run into an incomplete mirror or a damaged file on a mirror.
It's not really a yum bug.
Comment 3 Thierry moisan 2004-10-01 07:05:43 EDT
Yeah, but it's on the offcial miror of fc3test2 so... where should I
post this?
Comment 4 David Wood 2004-10-07 10:37:58 EDT
I'm seeing this as well.
I have always used yum to update/upgrade successfully.
I sit behind an http proxy server and define http_proxy=http://... to
make yum work.
I use a fast local mirror which I can manually download from without
any problem.
I couldn't use yum-2.0.7-1.1 to update FC3T1 to FC3T2 because of the
base-fonts conflict.  However, I worked around this by downloading and
installing the xorg-x11* and fonts-xorg* rpm's manually.  I could then
use yum to do the rest.  So I am now at FC3T2.

The problem is that every version of yum (up to 2.1.5) I've tried
since yum-2.0.7 just won't work.  The header downloading seems really
slick in the new versions, and yum check-update works fine.  But when
I do yum update I get this:

# yum update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 927 kB    00:03
developmen: ################################################## 3423/3423
Resolving Dependencies
gcc-java-3.4.2-4.i386.rpm 100% |=========================| 1.8 MB    00:02
Fedora/RPMS/gcc-java-3.4.2-4.i386.rpm: [Errno -1] Header is not complete.
Error: failure: Fedora/RPMS/gcc-java-3.4.2-4.i386.rpm from development:
[Errno 256] No more mirrors to try.

I've gone back to using yum-2.0.7-1.1 and that works just fine.
Comment 5 Seth Vidal 2004-10-07 10:44:49 EDT
Are you using the mirror master? download.fedora.redhat.com?

If so - find a mirror and use it.

The primary cannot support all of these people accessing it.
Comment 6 David Wood 2004-10-08 04:58:18 EDT
No, not exclusively.  I've tried the uk http zeniiia mirror,
mirrorservice.org, mirror.hiwaay.net as well as
download.fedora.redhat.com (just to check it wasn't a mirroring
problem).  All showed the same problem unless I was using 2.0.7. 
Having updated to yum 2.1.6 I'll keep you posted to see if it has gone
away yet.
Comment 7 David Wood 2004-10-08 09:18:00 EDT
No luck.  I'm fully up to date with the development tree, now with
yum-2.1.6, but still with the same problem, regardless of which mirror
I use. e.g.

$yum install xsnow
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3423/3423
Resolving Dependencies
xsnow-1.42-15.i386.rpm    100% |=========================|  34 kB    00:00
Fedora/RPMS/xsnow-1.42-15.i386.rpm: [Errno -1] Header is not complete.
Error: failure: Fedora/RPMS/xsnow-1.42-15.i386.rpm from development:
[Errno 256] No more mirrors to try.

Do you think this could be a http proxy issue?
Comment 8 Seth Vidal 2004-10-08 09:19:56 EDT
Are you going through a proxy of any type?

Also could you set keepalive=0 in each repository stanza and tell me
if it gets better?

Thanks
Comment 9 David Wood 2004-10-08 09:47:30 EDT
This is my yum.conf (minus commented out lines).  Hope I've put the
keepalive=0 in the right place.  It hasn't fixed the problem though. 
Not sure what I can tell you about our corporate proxy?  I just set it
to 10.0.20.15 port 80  which it uses for every usual protocol (http,
https, ftp).

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
retries=20

[development]
keepalive=0
name=Fedora Core $releasever - Development Tree
baseurl=http://mirror.hiwaay.net/redhat/fedora/linux/core/development/$basearch/
Comment 10 Thierry moisan 2004-10-09 07:51:06 EDT
After adding keepalive=0 in each repository, it solved the other
problem  I had with yum
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134474) but this
doesn't solve this one. I still get the header incomplete and Errno
256 thing. Ho and a difference for me : I'm not behind a proxy like
David Wood, I only have the fedora installation firewall on.
Thierry
Comment 11 David Wood 2004-10-15 04:46:35 EDT
Now I've updated to yum-2.1.7 (using good old yum-2.0.7) the error has
changed to this ...

$yum install xsnow
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3429/3429
base      : ################################################## 2615/2615
Resolving Dependencies
xsnow-1.42-15.i386.rpm    100% |=========================|  34 kB    00:00
Fedora/RPMS/xsnow-1.42-15.i386.rpm: <urlgrabber.grabber.CallbackObject
instance at 0xf2d99b6c>
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 149, in ?
    main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 96, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 168,
in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 170,
in resolveDeps
    self.populateTs(test=1)
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 128,
in populateTs
    self.downloadHeader(po)
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 418,
in downloadHeader
    end=end, checkfunc=checkfunc, copy_local=1)
  File "/usr/lib/python2.3/site-packages/yum/repos.py", line 432, in get
    checkfunc=checkfunc)
  File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.3/site-packages/urlgrabber/mirror.py", line
400, in _mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
597, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.3/site-packages/urlgrabber/grabber.py", line
544, in _retry
    cb_func(obj, *cb_args, **cb_kwargs)
  File "/usr/share/yum-cli/output.py", line 41, in failureReport
    raise msg
urlgrabber.grabber.CallbackObject: <urlgrabber.grabber.CallbackObject
instance at 0xf2d99b6c>

Hope this is more enlightening!
Comment 12 Thierry moisan 2004-10-16 13:42:05 EDT
Doesn't happen anymore for me with yum-2.1.7-2 and the keepalive=0 thing.
Comment 13 David Wood 2004-10-18 11:55:47 EDT
I just don't seem to have any luck here!  I'm now at yum-2.1.8, with
the keepalive=0 thing and I'm now getting this ...

$yum install xsnow
Traceback (most recent call last):
  File "/usr/bin/yum", line 6, in ?
    import yummain
ImportError: No module named yummain

Hmmmm?  It just doesn't get any better!  Keep trying ...
Comment 14 Seth Vidal 2004-10-18 12:44:13 EDT
go get 2.1.9 from:
http://people.redhat.com/katzj/yum-2.1.9-1.noarch.rpm

Comment 15 David Wood 2004-10-19 05:10:44 EDT
Thanks. I'm now back to the original problem.  I can see the initial
informational outputs have changed (see below), but the traceback is
identical.
[Using the default yum.conf this time]
$yum install xsnow
not using ftp, http[s], or file for repos, skipping -
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3433/3433
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xsnow to pack into transaction set.
xsnow-1.42-15.i386.rpm    100% |=========================|  34 kB    00:00
Fedora/RPMS/xsnow-1.42-15.i386.rpm: <urlgrabber.grabber.CallbackObject
instance at 0xf4b5d86c>
Traceback (most recent call last):
... as #11.

If I can do anything to generate more useful diagnostics, let me know.
Comment 16 David Wood 2004-10-20 08:18:27 EDT
Now at yum-2.1.10-1 and I'm back to [Errno 256] as per comment #4.
If it's not bothering anyone else, I still think this must be a proxy
issue (which wasn't in 2.0.7).
Comment 17 David Wood 2004-11-01 06:39:56 EST
If this helps (now at yum-2.1.11-2), it seems that wget can get the
rpm ok, but yum can't.  I'm sure this will start to bite some users
once FC3 is out but I seem to be a lone voice at the moment :(

$yum -d10 install xsnow
Yum Version: 2.1.11
COMMAND: yum -d10 install xsnow
Installroot: /
Ext Commands:
   xsnow
Setting up Install Process
Setting up Repo:  development
Baseurl(s) for repo:
['http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/']
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Setting up Package Sacks
developmen: ################################################## 3426/3426
Reading Local RPMDB
reduced installs :
   xsnow.i386 0:1.42-15
Resolving Dependencies
1099308823.04
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xsnow to pack into transaction set.
xsnow-1.42-15.i386.rpm    100% |=========================|  34 kB    00:00
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm:
[Errno -1] Header is not complete.
Trying other mirror.
Error: failure: Fedora/RPMS/xsnow-1.42-15.i386.rpm from development:
[Errno 256] No more mirrors to try.

So I tried this ...

$wget
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm
--11:36:25-- 
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm
           => `xsnow-1.42-15.i386.rpm'
Connecting to 10.0.20.15:80... connected.
Proxy request sent, awaiting response... 200 OK
Length: 34,473 [application/x-rpm]

100%[=====================================================================================================================>]
34,473        --.--K/s

11:36:25 (987.68 KB/s) - `xsnow-1.42-15.i386.rpm' saved [34,473/34,473]

I was then able to install the rpm without any difficulty.
Comment 18 Seth Vidal 2004-11-01 11:32:29 EST
the above is an unfair comparison - in the first case yum is
downloading a byte range of just the header. but wget is downloading
the whole file.

What other mirrors have you tried?
Comment 19 David Wood 2004-11-01 11:48:26 EST
See comment #6 .  I didn't give up trying alternatives that easily :)
Comment 20 David Wood 2004-11-03 07:57:56 EST
Some more useful clues: having looked at the yum-devel list re.
urlgrabber - new request of silliness, I wondered if I had an http
proxy that didn't support byte ranges. I downloaded my xsnow test rpm
using wget and chopped off the end.  I then repeated the wget with the
-c parameter (which should continue the download if Range is
supported).  The result ...

wget -c
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm
--12:46:25-- 
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm
           => `xsnow-1.42-15.i386.rpm'
Connecting to 10.0.20.15:80... connected.
Proxy request sent, awaiting response... 200 OK

Continued download failed on this file, which conflicts with `-c'.
Refusing to truncate existing file `xsnow-1.42-15.i386.rpm'.

So I tried wget with our ftp proxy server ...

wget -c
ftp://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm
--12:46:57-- 
ftp://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/Fedora/RPMS/xsnow-1.42-15.i386.rpm
           => `xsnow-1.42-15.i386.rpm'
Connecting to 10.0.20.17:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD
/redhat/fedora/linux/core/development/i386/Fedora/RPMS ... done.
==> SIZE xsnow-1.42-15.i386.rpm ... done.
==> PASV ... done.    ==> REST 32,273 ... done.
==> RETR xsnow-1.42-15.i386.rpm ... done.
Length: 34,473 [2,200 to go]

100%[+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++=======>]
34,473        --.--K/s

12:46:59 (153.34 KB/s) - `xsnow-1.42-15.i386.rpm' saved [34,473]

SUCCESS!!  Note the [2,200 to go] seemed to work OK.  So I tried the
ftp proxy with yum (after doing export ftp_proxy=ftp://10.0.20.17:21)
but I get this ...

yum install xsnow
Setting up Install Process
Setting up Repo:  development
ftp://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/repodata/repomd.xml:
[Errno 4] IOError: [Errno ftp error] 501 Use user@site to connect via
proxy
Trying other mirror.
Cannot open/read repomd.xml file for repository: development
failure: repodata/repomd.xml from development: [Errno 256] No more
mirrors to try.

Looks like the anonymous ftp login process (which works for wget) is
falling over.  Any ideas how to get round this?  Any progress on the
urlgrabber silliness!  Maybe if range isn't supported, the whole rpm
could be grabbed anyway.  In fact, for an rpm install, why are you
just grabbing the header?  Have I lost the plot?
Comment 21 Rahul Sundaram 2005-06-18 22:54:41 EDT

This is probably a repository issue during the development release which has
subsequently been fixed now


This bug report should be closed
Comment 22 David Wood 2005-06-20 05:33:43 EDT
I support the closure of this bug.  I have opened bug 160323 against FC4 re.
lack of support for proxy servers that do not accept byte range requests.

Note You need to log in before you can comment on or make changes to this bug.