Bug 134302 - gnome-cd no cddb info
gnome-cd no cddb info
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 01:55 EDT by John MacLean
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John MacLean 2004-10-01 01:55:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040929
Firefox/0.10

Description of problem:
gnome-cd does not display cddb information.
At least not until the cd player applet if first run, the gnome-cd
cddb works fine.

Version-Release number of selected component (if applicable):
gnome-media-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1.insert cd
2.run gnome-cd
3.
    

Actual Results:  CDs would play but cddb info not displayed. First CD
attempted is somewhat obsure so I repeated with several top-selling discs.

Expected Results:  cddb info displayed in player.

Additional info:

1) Running from command line gives the following:
** (gnome-cd:8812): WARNING **: Could not contact CDDB server

2) cddb works for sound-juicer and grip.

3) If I use grip on a CD, it saves the cddb file to ~/.cddb. If I then
open gnome-cd the cddb info is displayed and the same file appears in
~/.cddbslave (I'll be opening another bug for these to share a dir).
Sound juicer doesn't have this effect.

4) Looking for other cd apps to try, I added the cd player applet to
my panel. It doesn't display cddb info, but...

5) gnome-cd cddb info now works! Even if I put in a CD never
previously loaded on this PC.
Comment 1 Colin Walters 2004-10-15 14:30:28 EDT
And if you remove ~/.cddb it stops working again?
Comment 2 John MacLean 2004-10-29 23:18:41 EDT
Sorry for the delay.
~/.cddb seems to be a grip only dir. I didn't have this dir as of step
5) above. ~/.cddbslave is relevant.
At one point last week I was deleting the .cddbslave directory and
having the problem. I had to use a 'fresh' cd and no ~/.cddbslave. But
sometimes this scenario did work. Always worked if .cddbslave present
and/or if the CD had been inserted previously.
So tonight I created some new user and inserted some new CD. Track
listing d/l successfully each time.
I considered it closed.
Comment 3 Colin Walters 2004-10-29 23:37:06 EDT
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.