Bug 1343075 - exclamation mark in error message is not evident
Summary: exclamation mark in error message is not evident
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Soumya Deb
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-06 13:03 UTC by Martin Kudlej
Modified: 2016-08-23 19:54 UTC (History)
5 users (show)

Fixed In Version: rhscon-ui-0.0.46-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:54:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
exclamation mark is not properly visible (7.42 KB, image/png)
2016-06-06 13:03 UTC, Martin Kudlej
no flags Details
exclamation mark is properly visible after zoom (9.41 KB, image/png)
2016-06-06 13:05 UTC, Martin Kudlej
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-06-06 13:03:20 UTC
Created attachment 1165203 [details]
exclamation mark is not properly visible

Description of problem:
As you can see at screenshot exclamation mark at end of error message is not obvious. It seems that sentence continues and rest of it is hidden. Only if user zooms page user can see that it is exclamation mark.

Version-Release number of selected component (if applicable):
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-core-0.0.21-1.el7scon.x86_64
rhscon-ui-0.0.35-1.el7scon.noarch

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36
Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0

How reproducible:
100%

Steps to Reproduce:
1. open cluster create wizard
2. cluster name leave empty and input journal size to 0
3. check end of error messages

Actual results:
It is not obvious that at end of error messages is exclamation mark and it seems like end of sentence is hidden.

Expected results:
Exclamation marks are obvious.

Comment 1 Martin Kudlej 2016-06-06 13:05:02 UTC
Created attachment 1165206 [details]
exclamation mark is properly visible after zoom

Comment 2 Ju Lim 2016-06-07 16:47:07 UTC
Although the exclamation mark is not visible completely (which is the actual bug), from a UX perspective, we would suggest removing exclamation marks from all error/warning messages.

As a best practice, the error/warning message should:

(1) Avoid using exclamation marks in the message as this could be perceived as "scolding" the user.

(2) You probably don't need to use camel case in the message, e.g. Journal Size can be written as Journal size in the message.

(3) Error/warning messages should be helpful, e.g.

    Invalid journal size. Specify a journal size value between 2 and 1024.

Related to https://bugzilla.redhat.com/show_bug.cgi?id=1343097.

Suggested priority is low and can be addressed after feature freeze.

Comment 3 :Deb 2016-06-08 14:19:06 UTC
Agreed with Ju here, in favor of removing the exclamation mark.

However, we should be careful selecting typefaces, cause in some scenario an exclamation mark is completely viable and this bug will crop up no matter what.

Comment 4 :Deb 2016-06-15 13:15:30 UTC
Under review: https://review.gerrithub.io/#/c/280398/

Comment 5 :Deb 2016-06-20 12:14:46 UTC
Fixed on the upstream: https://review.gerrithub.io/#/c/280398/

Moving to ON_QA

Comment 6 Martin Kudlej 2016-07-15 06:47:57 UTC
Tested with
ceph-ansible-1.0.5-25.el7scon.noarch
ceph-installer-1.0.12-4.el7scon.noarch
rhscon-ceph-0.0.32-1.el7scon.x86_64
rhscon-core-0.0.33-1.el7scon.x86_64
rhscon-core-selinux-0.0.33-1.el7scon.noarch
rhscon-ui-0.0.47-1.el7scon.noarch
and it works.

Comment 8 errata-xmlrpc 2016-08-23 19:54:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.