Bug 134308 - HTML message which kills future HTML message display
HTML message which kills future HTML message display
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2004-10-01 05:02 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 20:17:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mailbox containing trigger HTML message (27.13 KB, application/octet-stream)
2004-10-01 05:03 EDT, Tim Waugh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 267496 None None None Never

  None (edit)
Description Tim Waugh 2004-10-01 05:02:09 EDT
Description of problem:
Attached is a mail box containing a message which, once viewed, causes
evolution not to display any HTML messages at all.

Version-Release number of selected component (if applicable):
evolution-2.0.1-2
gtkhtml3-3.3.2-3

How reproducible:
100%

Steps to Reproduce:
1. View an HTML message
2. View the message that is attached
3. Try to view the HTML message as in step 1

Actual results:
The other HTML message can be viewed correctly in step 1, but not at
all in step 3.
Comment 1 Tim Waugh 2004-10-01 05:03:19 EDT
Created attachment 104621 [details]
Mailbox containing trigger HTML message
Comment 2 Dave Malcolm 2004-10-01 14:20:23 EDT
Thanks; I can reproduce the bug here.   I've done a little more
investigation, am about to dig out the source.  

It seems to only affect the email Preview pane for me, if I
double-click on other emails to open them in separate windows, they
still appear as normal for me, after viewing the attached email (both
in preview mode, and as a full window).  Can you verify that this is
what happens for you?  So I think that some state is getting set into
the preview window that's breaking it permanently (until evolution is
restarted).  

Also, having performed the various steps, I can do a Print Preview and
"see" other HTML emails, but the email you attached comes out blank
for me in Print Preview too.
Comment 3 Tim Waugh 2004-10-03 10:49:21 EDT
Yes, it's just the preview pane (sorry, I forgot to say that originally).
Comment 4 Christopher A. Williams 2004-11-05 10:16:14 EST
Actually for me it's more than just the preview pane. Opening the
message in its own window will sometimes work - but other times the
message will not display no matter what you do. I can't find any other
pattern to this behavior. It does appear to be messages that use CSS
tags in particular, or sometimes messages where the HTML portion is a
MIME attachment.

I'm using:
evolution-2.0.2-3
gtkhtml-1.1.9-10

Hope that helps some more.
Comment 5 Kjartan Maraas 2004-11-09 16:05:18 EST
Seeing the same here with current packages from rawhide. Strange thing
is that I only saw it earlier today on an IMAP account, and I can't
reproduce it now using my local mailstore from my pop3 account... Just
some input...
Comment 7 Dave Malcolm 2004-12-16 23:03:11 EST
(possibly related to bug #138274: see especially comment 5 of that bug)
Comment 8 Tom Duffy 2005-01-05 19:06:39 EST
Looks like this was fixed in evolution 2.0.3:

XB67496 - html email not rendered in preview pane (Michael)

Are we going ot see this as an update to FC3?

-tduffy
Comment 10 Dave Malcolm 2005-08-29 20:17:17 EDT
An update to Evolution 2.0.4 has been released; this ought to fix this issue. 
I'm going to close this bug.  Please reopen it if you're still seeing these
symptoms with the latest FC3 packages.

Note You need to log in before you can comment on or make changes to this bug.