Bug 134311 - IIIMF: Three-language setting
IIIMF: Three-language setting
Status: CLOSED DUPLICATE of bug 131217
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-10-01 05:57 EDT by Timothy Ha
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Ha 2004-10-01 05:57:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
I have problems with my three-language setting. My organization needs
three languages. But Korean works by Ctrl-Space
switching only when I enter GNOME with Korean interface. When I am in
English or Russian interface, I can use only the English+Russian pair.

I installed FC3t2 with ALL packages.

Perhaps, I need to uninstall IIIMF-Chinese and IIIMF-Japanese to make
IIIMF sure that it deals with Korean. But is there another way to
ensure that IIIMF is activated and working in GNOME when I am not in
CJK interface?

Adding Korean to GNOME layouts would give XKB error - an old bug (or a
way it should happen?)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora with all packages
2. Choose Korean language at entry. It works within thru Ctrl-Space
3. Choose English at entry. It works with Russian (added by Gnome
layouts), but not Korean.
    

Actual Results:  I cannot use three languages at the same time in an
English interface. FC2 could handle this.

Expected Results:  In English interface I should be able to switch
English-Russian by GNOME layouts, for example thru Ctrl-Shift.
And Korean should be available thru Ctrl-Space.

Additional info:
Comment 1 Leon Ho 2004-10-01 13:05:28 EDT
As I mentioned in #134213 as well, for switching LEs in IIIMF, you can
use a applet called GIMLET to switch between language engines in IIIMF.

If you only add Korean into gimlet language menu, you should able to
use korean only, which is what you want.
Comment 2 Timothy Ha 2004-10-03 13:21:30 EDT
Even though I have all packages, when I add GIMLET to the panel and
choose its preferences, I don't see any language in the column titled
"Available languages".

It should have contained Korean, Chinese and Japanese, and something else?
Comment 3 Leon Ho 2004-10-03 20:29:26 EDT
Yes, it's related to bug 131217. So try to run a application (i.e.
gedit) first before configuring it.
Comment 4 Leon Ho 2004-10-07 23:45:10 EDT
Closing now as a duplicate of bug 131217. Please submit a new but if
you encounter more problems than bug 131217.

*** This bug has been marked as a duplicate of 131217 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:06:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.