Bug 1343226 - plugin rhel-push-plugin failed with error for Ruby Sample App
Summary: plugin rhel-push-plugin failed with error for Ruby Sample App
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jhon Honce
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-06 20:48 UTC by Vikas Laad
Modified: 2017-03-08 18:26 UTC (History)
8 users (show)

Fixed In Version: docker-1.10.3-46.el7.10
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: Rebase from upstream code Result: Build Successful, application is deployed.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:33:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
Build logs (3.65 KB, text/plain)
2016-06-06 20:48 UTC, Vikas Laad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Vikas Laad 2016-06-06 20:48:44 UTC
Created attachment 1165405 [details]
Build logs

Description of problem:
When trying to create a Ruby app using a template https://raw.githubusercontent.com/openshift/svt/master/reliability/ruby-helloworld-sample.json build is failing randomly in multiple projects. I was running reliability tests and this happens with some builds and other builds are fine.

Version-Release number of selected component (if applicable):
openshift v3.2.1.1-1-g33fa4ea
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5


root@ip-172-31-32-121: ~ # docker version
Client:
 Version:         1.10.3
 API version:     1.22
 Package version: docker-common-1.10.3-25.el7.x86_64
 Go version:      go1.4.2
 Git commit:      86bbf84/1.10.3
 Built:           
 OS/Arch:         linux/amd64

Server:
 Version:         1.10.3
 API version:     1.22
 Package version: docker-common-1.10.3-25.el7.x86_64
 Go version:      go1.4.2
 Git commit:      86bbf84/1.10.3
 Built:           
 OS/Arch:         linux/amd64

How reproducible:
Frequently

Steps to Reproduce:
1. Create an app using template mentioned above
2. Watch the build, notice error

Actual results:
F0606 16:18:33.838790       1 builder.go:204] Error: build error: Failed to push image: API error (500): plugin rhel-push-plugin failed with error: Post http:///run/docker/plugins/rhel-push-plugin.sock/AuthZPlugin.AuthZReq: http: ContentLength=233 with Body length 0


Expected results:
Build Successful, application is deployed.

Additional info:

Comment 1 Antonio Murdaca 2016-06-10 09:00:26 UTC
Can you try with the latest docker shipped in RHEL as well as the latest RHEL-push-plugin? we've fixed a bug also in rhel-push-plugin in https://bugzilla.redhat.com/show_bug.cgi?id=1344448 (Lokesh should rebuild it today probably)

Comment 2 Vikas Laad 2016-06-10 13:43:13 UTC
(In reply to Antonio Murdaca from comment #1)
> Can you try with the latest docker shipped in RHEL as well as the latest
> RHEL-push-plugin? we've fixed a bug also in rhel-push-plugin in
> https://bugzilla.redhat.com/show_bug.cgi?id=1344448 (Lokesh should rebuild
> it today probably)

I will restart the tests once new build is available.

Comment 3 Jhon Honce 2016-08-16 22:17:56 UTC
What were the results from the follow-on testing?

Comment 4 Mike Fiedler 2016-08-17 02:07:58 UTC
Latest Atomic Docker fixes the bug.

Comment 6 Vikas Laad 2016-08-17 13:21:54 UTC
I have not seen this issue with the recent builds.

Comment 9 errata-xmlrpc 2016-09-27 09:33:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.