Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1343233 - [RFE] Add capability to re-run deployment and skip steps which finished successfuly
Summary: [RFE] Add capability to re-run deployment and skip steps which finished succe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Upstream M2
: 14.0 (Rocky)
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1615694
TreeView+ depends on / blocked
 
Reported: 2016-06-06 21:30 UTC by Matt Flusche
Modified: 2019-12-16 05:53 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-9.0.0-0.20180710202746.d2994ca.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:47:58 UTC

Description Matt Flusche 2016-06-06 21:30:41 UTC
Description of problem:

Add the ability to run the Overcloud post configuration steps in a stand-alone mode.

Many Overcloud deployments fail in the post deployment steps (After the heat deployment has completed successfully).  This occurs often due to network connectivity between Director and the Overcloud's public Keystone API endpoint. Having a quick way to complete the Overcloud installation without re-running the entire deployment would be very helpful.

Additional, often the Overcloud's heat stack_status is used to determine the entire deployments status.  Having a quick way to verify the post configuration status also would help close this gap.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 16 Artem Hrechanychenko 2018-11-29 07:49:17 UTC
VERIFIED

Comment 18 errata-xmlrpc 2019-01-11 11:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.