Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1343333 - [RFE] Simplify Non Root Geo-replication Setup
Summary: [RFE] Simplify Non Root Geo-replication Setup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1359605
TreeView+ depends on / blocked
 
Reported: 2016-06-07 07:35 UTC by Aravinda VK
Modified: 2017-03-27 18:19 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1359605 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:19:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-06-07 07:35:14 UTC
Description of problem:
Simplify the Non root user Geo-rep setup steps

Comment 1 Vijay Bellur 2016-06-07 07:35:42 UTC
REVIEW: http://review.gluster.org/14544 (geo-rep: Simplify Non root user(mountbroker) Setup) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-08-25 08:11:17 UTC
REVIEW: http://review.gluster.org/14544 (geo-rep: Simplify Non root user(mountbroker) Setup) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Worker Ant 2016-08-30 14:21:21 UTC
REVIEW: http://review.gluster.org/14544 (geo-rep: Simplify Non root user(mountbroker) Setup) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Worker Ant 2016-08-31 05:22:59 UTC
COMMIT: http://review.gluster.org/14544 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 55c255b27a99f027cb716800f8330f8faa4eb1f5
Author: Aravinda VK <avishwan@redhat.com>
Date:   Thu May 26 15:52:53 2016 +0530

    geo-rep: Simplify Non root user(mountbroker) Setup
    
    Setting up Non root Geo-replication is troublesome. Lot of steps
    involved like user setup, directory creation, setting up proper
    permissions, editing glusterd.vol file etc.
    
    Introducing `gluster-mountbroker` command, with this tool non root
    user setup steps are(Run the following commands in any one Slave
    node),
    
        gluster-mountbroker setup <MOUNT ROOT> <GROUP>
    
    For example,
    
        gluster-mountbroker setup /var/mountbroker-root geogroup
    
    Add user using,
    
        gluster-mountbroker add <VOLUME> <USER>
    
    For example,
    
        gluster-mountbroker add slavevol geoaccount
    
    Remove user or Volume using,
    
        gluster-mountbroker remove [--volume <VOLUME>] [--user <USER>]
    
    Example,
    
        gluster-mountbroker remove --volume slavevol --user geoaccount
        gluster-mountbroker remove --user geoaccount
        gluster-mountbroker remove --volume slavevol
    
    Check the status of setup using,
    
        gluster-mountbroker status
    
    Once the changes are complete, restart glusterd in all Slave nodes.
    and follow the Geo-rep instructions.
    
    Change-Id: Ied3fa009df6a886b24ddd86d39283fcfcff68c82
    BUG: 1343333
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/14544
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:19:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.