Bug 1343382 - dnf packager uses obsolete function sigCheckPkg
Summary: dnf packager uses obsolete function sigCheckPkg
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.packagers
Version: master
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.0.1
: 1.5.1
Assignee: Yedidyah Bar David
QA Contact: Gonza
URL:
Whiteboard:
: 1347222 (view as bug list)
Depends On:
Blocks: 1306739
TreeView+ depends on / blocked
 
Reported: 2016-06-07 08:55 UTC by Amit Aviram
Modified: 2019-04-28 13:37 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: otopi's dnf plugin used an unofficial function to check for package signatures, and at some point this function was removed from dnf. Consequence: otopi tools that use dnf are broken, including engine-setup and host-deploy. Fix: For now, the fix was to remove the call. A separate bug was opened to restore the check, when dnf adds an official api for this. Result: otopi tools are not broken, but also do not check package signatures.
Clone Of:
Environment:
Last Closed: 2016-07-26 10:53:48 UTC
oVirt Team: Integration
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
ylavi: Triaged+
rule-engine: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
Engine logs (898.36 KB, text/plain)
2016-06-07 08:55 UTC, Amit Aviram
no flags Details
host-deploy logs (2.67 MB, text/plain)
2016-06-07 08:56 UTC, Amit Aviram
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58906 0 master MERGED packagers: minidnf: Do not check signature 2020-12-17 14:52:55 UTC
oVirt gerrit 59494 0 otopi-1.5 MERGED packagers: minidnf: Do not check signature 2020-12-17 14:52:55 UTC

Description Amit Aviram 2016-06-07 08:55:42 UTC
Created attachment 1165544 [details]
Engine logs

Description of problem:
When installing a host, and after manually installing pyhton-dnf in the host to be added to oVirt (Known Bug 1316950) - host installation is failing with the following error in the deploy logs:

Traceback (most recent call last):
  File "/tmp/ovirt-cAfauT2GHB/pythonlib/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/tmp/ovirt-cAfauT2GHB/otopi-plugins/otopi/packagers/dnfpackager.py", line 240, in _packages
    self._minidnf.processTransaction()
  File "/tmp/ovirt-cAfauT2GHB/pythonlib/otopi/minidnf.py", line 646, in processTransaction
    self._processTransaction(base=self._base)
  File "/tmp/ovirt-cAfauT2GHB/pythonlib/otopi/minidnf.py", line 627, in _processTransaction
    result, errmsg = base.sigCheckPkg(po)
TypeError: 'NoneType' object is not iterable


Version-Release number of selected component (if applicable):
master

How reproducible:
100% in my environment

Steps to Reproduce:
1. Have two fc23 hosts
2. Install the latest ovirt-engine on one of the hosts
** ovirt-imageio-proxy was also installed, don't know if that's matter- but that's my environment, so worth mentioning.
3. install python-dnf in the other host, to be added to oVirt
4. add the host to oVirt

Actual results:
host installation fails. in the host deploy logs, I get the message shown above.

Expected results:
...

Additional info:

Comment 1 Amit Aviram 2016-06-07 08:56:26 UTC
Created attachment 1165546 [details]
host-deploy logs

Comment 2 Yedidyah Bar David 2016-06-09 10:31:49 UTC
Now happened to me during engine-setup on fedora 23 with updated dnf.

Will simply remove the check, opened bug 1344270 for restoring it.

Comment 3 Yedidyah Bar David 2016-06-16 11:35:13 UTC
*** Bug 1347222 has been marked as a duplicate of this bug. ***

Comment 4 Piotr Kliczewski 2016-06-16 12:20:40 UTC
*** Bug 1347222 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Svaty 2016-07-26 10:53:48 UTC
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.