Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1343439 - Kdevelop crashes on creating a new project
Summary: Kdevelop crashes on creating a new project
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdevelop
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-07 11:05 UTC by Dr I J Ormshaw
Modified: 2016-06-26 20:56 UTC (History)
6 users (show)

Fixed In Version: kdevelop-5.0.0-0.1.20160608git.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-26 20:56:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Dr I J Ormshaw 2016-06-07 11:05:31 UTC
Description of problem:

Creating a new project in kdevelop causes kdevelop to crash

Version-Release number of selected component (if applicable):

Fedora 24 Beta
Kdevelop 4.90.91

How reproducible:

Every time

Steps to Reproduce:
1. run kdevelop
2. create a new session
3. create a new project from template
4. select Standard / Terminal and enter a name
5. select next
6. version control: none
7. select finish
8. select Ok

Actual results:

kdevlop configures the project then crashes 

Expected results:

It should not crash

Additional info:

I get the same problem using the live CD Fedora-KDE-Live-x86_64-24_Beta-1.6.iso
and after a dnf upgrade from Fedora 23


[ian@ormshaw Downloads]$ kdevelop
kdevplatform.plugins.git: couldn't find the git root for QUrl("file:///home/ian/projects/newProject")
job started 0x5633d55a5c90
job failed SvnInternalInfoJob(0x5633d55a5c90)
Invalid return type in method "core"
Invalid return type in method "extensions"
/usr/bin/cat: /home/ian/.local/share/kdevelop/sessions/{9626798b-04cd-4c4d-aae9-91f963c666aa}/default.sh: No such file or directory
Invalid return type in method "core"
Invalid return type in method "extensions"
Segmentation fault (core dumped)
[ian@ormshaw Downloads]$

Comment 1 Jan Grulich 2016-06-07 17:17:11 UTC
That's due to GCC 6, I was hoping that KDevelop 5.0 gets released before Fedora 24 gets released, but it looks I'll have to package a git snapshot where this is already solved. I'll do that tomorrow.

Comment 2 Rex Dieter 2016-06-07 17:18:55 UTC
I'll see if the fix(es) are easily cherry-picked or not (which is usually easier than doing a full snapshot).

Comment 3 Rex Dieter 2016-06-07 17:29:34 UTC
hrm, no obvious fixes in 5.0 branches of either kdevplatform or kdevelop I notice offhand (nothing with words: "crash" and/or "gcc6" anyway).  snapshot it is :)

Comment 4 Fedora Update System 2016-06-08 12:37:23 UTC
kdevplatform-5.0.0-0.1.20160608git.fc24 kdevelop-5.0.0-0.1.20160608git.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-69e396e7ff

Comment 5 Fedora Update System 2016-06-08 17:54:41 UTC
kdevelop-5.0.0-0.1.20160608git.fc24, kdevplatform-5.0.0-0.1.20160608git.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-69e396e7ff

Comment 6 Fedora Update System 2016-06-08 18:00:58 UTC
kdevelop-5.0.0-0.1.20160608git.fc24 kdevelop-php-5.0.0-0.1.20160608git.fc24 kdevelop-python-5.0.0-0.1.20160608git.py3.fc24 kdevplatform-5.0.0-0.1.20160608git.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-69e396e7ff

Comment 7 Dr I J Ormshaw 2016-06-09 09:44:06 UTC
I've created new projects and build from kdevelop 4 projects without ant crashes

Comment 8 Fedora Update System 2016-06-09 16:55:56 UTC
kdevelop-5.0.0-0.1.20160608git.fc24, kdevelop-php-5.0.0-0.1.20160608git.fc24, kdevelop-python-5.0.0-0.1.20160608git.py3.fc24, kdevplatform-5.0.0-0.1.20160608git.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-69e396e7ff

Comment 9 Fedora Update System 2016-06-26 20:56:25 UTC
kdevelop-5.0.0-0.1.20160608git.fc24, kdevelop-php-5.0.0-0.1.20160608git.fc24, kdevelop-python-5.0.0-0.1.20160608git.py3.fc24, kdevplatform-5.0.0-0.1.20160608git.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.