Bug 134351 - Gettext should require gcc-java at building time
Gettext should require gcc-java at building time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 11:42 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 13:42:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-10-01 11:42:36 EDT
Description of problem:
--- snipp ---
make[3]: Entering directory `/usr/src/redhat/BUILD/gettext-0.14.1/gettext-runtime/intl-java'
/bin/sh ../lib/javacomp.sh -d . ./gnu/gettext/GettextResource.java
libgcj-java-placeholder.sh

This script is a placeholder for the /usr/bin/java and /usr/bin/javac
master links required by jpackage.org conventions.  libgcj's
rmiregistry, rmic and jar tools are now slave symlinks to these
masters, and are managed by the alternatives(8) system.

This change was necessary because the rmiregistry, rmic and jar tools
installed by previous versions of libgcj conflicted with symlinks
installed by jpackage.org JVM packages.
jar cf libintl.jar gnu/gettext/GettextResource*.class
gnu/gettext/GettextResource*.class: No such file or directory
Error adding gnu/gettext/GettextResource*.class to jar archive!
make[3]: *** [libintl.jar] Error 1
--- snapp ---

Version-Release number of selected component (if applicable):
gettext-0.14.1-9

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. rpm -e gcc-java libgcj libgcj-devel
2. rpmbuild --rebuild gettext-0.14.1-9.src.rpm
3. Die with the error above.
  
Actual results:
gettext has no build requirement to gcc-java.

Expected results:
gettext should require gcc-java (and maybe other related java things)
at building time.
Comment 1 Leon Ho 2004-10-01 13:42:12 EDT
Thanks for the report. Fixed on -10.

Note You need to log in before you can comment on or make changes to this bug.