Bug 134352 - Cannot start GNOME with new kernel
Cannot start GNOME with new kernel
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-10-01 11:55 EDT by deryl sequeira
Modified: 2015-01-04 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-20 15:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xfree86.0.log (30.47 KB, text/plain)
2004-10-01 11:57 EDT, deryl sequeira
no flags Details
XF86Config (3.08 KB, text/plain)
2004-10-01 11:58 EDT, deryl sequeira
no flags Details

  None (edit)
Description deryl sequeira 2004-10-01 11:55:16 EDT
Description of problem:
When I click on the Red Hat Network Alert notification tool it tells
me the following:

"Your system is currently running kernel-2.4.21-4.EL, but the newest
installed kernael is kernel-2.4.21-20.EL. It is recommended that you
reboot at the first opportunity to test this new kernel."

So I reboot and choose this new kernel version but I get the following

"I cannot start the X server...."

It asks me if I want to see the error diagnostics I say yes and it
gives me some info which I have no idea about and then it asks me if I
want to run the X server configuration utility. I say yes but it comes
back with the ssame error message.

So essentially I cannot get the GUI interface to come up if I select
it to use the new kernel.

I apologize if I sound vague but I am very, very, very new to Linux
and am just finding my way around.

Version-Release number of selected component (if applicable):

How reproducible:
Rebbot and choose the new kernel

Steps to Reproduce:
2.Chose new kernel
Actual results:
Do not get GNOME gui

Expected results:
WOuld liek to get my GNOME window

Additional info:
Comment 1 deryl sequeira 2004-10-01 11:57:11 EDT
Created attachment 104634 [details]
Comment 2 deryl sequeira 2004-10-01 11:58:26 EDT
Created attachment 104635 [details]
Comment 3 Suzanne Hillman 2004-10-01 13:24:23 EDT
Does the error you see have anything to do with agpgart?
Comment 4 deryl sequeira 2004-10-04 10:28:01 EDT
I have no idea..
That is why i posted the error here hoping someone could tell me.
Comment 5 Suzanne Hillman 2004-10-04 14:16:38 EDT
Ok... I'm not seeing any errors in the attachments you included. I'm
wondering if perhaps there were errors that went to the screen but did
not get into the log you attached.

I would suggest, if this is something for which you have any sort of
time constraint, and you have a valid entitlement, that you contact
Red Hat's support at 800-RedHat1, or http://www.redhat.com/support.
Comment 6 deryl sequeira 2004-10-04 14:30:33 EDT
I just tried it again...and here is what it send to the screen..

(EE) GARTInit: Unable to open /dev/agpgart (No such device)
(EE) 1810(0): AGP GART support is not available. Make sure your 
kernel agpgart support or that the agpgart kernel module is loaded.
(EE) Screen(s) found, but none have a usable configuration.

Fatal Server Error:
no screens found

There is no time constraint for this issue..I can still use the old 
kernel till we find a solution

Comment 7 Suzanne Hillman 2004-10-04 14:53:14 EDT
Ah! Yes, it's agpgart. In which case, this is a known bug, and it's
being worked on. I shall duplicate this against the one that's being
worked, which I believe you ought to be able to see as well.

*** This bug has been marked as a duplicate of 131907 ***
Comment 8 deryl sequeira 2004-10-04 15:00:56 EDT
Thanks so much Suzanne.
Just one question though...should I download the "fixed" kernel 
submitted by a user or should I wait for the official relase from 

Sorry for sounding so clueless but I am...:)

Comment 9 Suzanne Hillman 2004-10-04 15:10:52 EDT
Depends on how willing you are to be working from non official
packages, really, and on how impatient you are to have the fix. 

Me, I'd probably wait, but I tend to avoid running code that is not
yet officially released on a machine I am doing active work with. That
said, if you decide to use it, it seems to be code with a very low
probability of causing problems.
Comment 10 deryl sequeira 2004-10-04 15:25:58 EDT

I guess I will wait for RedHat's official release...question is..how 
long will that be?
Are we talking a few weeks, a few months, a few years?

Also, how will I know when the release is available?
Will I be sent an email because I have a case opened or do I have to 
keep checking back?

Comment 11 Suzanne Hillman 2004-10-04 15:51:54 EDT
Should be before the end of the year.

Are you set up with RHN? That is how updates are distributed, and how
people are told that there are updates available.

To check, run 'up2date'. If it tells you that you need to be
registered, or something about needing a channel, you are not yet

In this case, you will need to activate your subscription. This can be
done through the following site: https://www.redhat.com/apps/activate/

After that is done, you will need to register your machine. There is
likely instructions for this on the site above, after you've activated
your subscription. If not, let me know.
Comment 12 Ernie Petrides 2004-10-18 23:18:55 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-22.EL).

*** This bug has been marked as a duplicate of 131907 ***
Comment 13 John Flanagan 2004-12-20 15:56:44 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.