Bug 1343540 (CVE-2016-1182) - CVE-2016-1182 struts: Improper input validation in Validator
Summary: CVE-2016-1182 struts: Improper input validation in Validator
Status: CLOSED WONTFIX
Alias: CVE-2016-1182
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20160607,repor...
Keywords: Security
Depends On: 1343542 1343541 1348088 1379733
Blocks: 1343545
TreeView+ depends on / blocked
 
Reported: 2016-06-07 12:38 UTC by Adam Mariš
Modified: 2017-05-17 06:08 UTC (History)
18 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-17 06:08:13 UTC


Attachments (Terms of Use)

Description Adam Mariš 2016-06-07 12:38:54 UTC
It was reported that The Apache Struts 1 Validator contains a vulnerability where input validation configurations (validation rules, error messages, etc.) may be modified. This occurs when ValidatorForm and ValidatorActionForm (including its subclasses) are in the session scope.

Affects Apache Struts 1 versions 1.0 through 1.3.10.

External References:

https://jvn.jp/en/jp/JVN65044642/

Comment 1 Adam Mariš 2016-06-07 12:40:19 UTC
Created struts tracking bugs for this issue:

Affects: fedora-all [bug 1343541]
Affects: epel-7 [bug 1343542]

Comment 2 gil cattaneo 2016-06-07 14:54:56 UTC
Seem a duplicate of CVE-2015-0899. Already fixed

Comment 5 Fedora Update System 2016-06-30 19:51:44 UTC
struts-1.3.10-18.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2016-06-30 21:26:57 UTC
struts-1.3.10-18.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Tomas Lestach 2016-12-01 09:45:42 UTC
Is there a tracking bug for RHEL6 builds?

Comment 12 Tomas Lestach 2016-12-02 09:06:33 UTC
Not saying we're shipping struts in RHEL6. But struts-1.3.10-6.ep5.el6 has been shipped in EAP5 or Satellite 5.
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=356255

Comment 13 gil cattaneo 2016-12-02 16:31:26 UTC
(In reply to Tomas Lestach from comment #12)
> Not saying we're shipping struts in RHEL6. But struts-1.3.10-6.ep5.el6 has
> been shipped in EAP5 or Satellite 5.
> https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=356255

Maybe is a mistake, because, I am not interested to mantain packages for these branches. Regards

Comment 14 Doran Moppert 2017-05-17 06:04:33 UTC
Statement:

This issue affects the version of struts shipped with Red Hat Enterprise Linux 5, which is currently in Extended Life Phase. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Issue Severity Classification https://access.redhat.com/security/updates/classification/ and the Red Hat Enterprise Linux Life Cycle https://access.redhat.com/support/policy/updates/errata/.


Note You need to log in before you can comment on or make changes to this bug.