Bug 1343553 - Network topology not shown for rhos undercloud provider with zero floating IPs
Summary: Network topology not shown for rhos undercloud provider with zero floating IPs
Keywords:
Status: CLOSED DUPLICATE of bug 1381862
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Andrey
QA Contact: Matouš Mojžíš
URL:
Whiteboard: provider:openstack:topology
Depends On:
Blocks: 1349420
TreeView+ depends on / blocked
 
Reported: 2016-06-07 12:50 UTC by Matouš Mojžíš
Modified: 2016-11-24 12:56 UTC (History)
9 users (show)

Fixed In Version: 5.7.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1349420 (view as bug list)
Environment:
Last Closed: 2016-11-21 15:23:03 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
production.log (13.76 KB, text/plain)
2016-11-07 16:50 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2016-06-07 12:50:31 UTC
Description of problem:
Network topology not shown for rhos undercloud, because it has no floating IPs. 

Version-Release number of selected component (if applicable):
5.6.0.9

How reproducible:
Always

Steps to Reproduce:
1. Add rhos undercloud provider
2. Make sure it has no floating IPs
3. Go to Networks -> Topology

Actual results:
FATAL -- : Error caught: [ActiveRecord::StatementInvalid] PG::UndefinedColumn: ERROR:  column floating_ips.host_id does not exist

Expected results:
Topology should be shown.

Additional info:

Comment 5 Tzu-Mainn Chen 2016-11-01 14:17:20 UTC
https://github.com/ManageIQ/manageiq/pull/11177

Comment 6 Matouš Mojžíš 2016-11-07 16:49:44 UTC
Still not working.
It works when I go to topology from provider summary, but not from networks -> topology.
Error log in production.log attached.

Comment 7 Matouš Mojžíš 2016-11-07 16:50:09 UTC
Created attachment 1218129 [details]
production.log

Comment 8 Matouš Mojžíš 2016-11-07 16:51:54 UTC
Tried it in 5.6.0.9.

Comment 9 Matouš Mojžíš 2016-11-07 16:56:14 UTC
Damn...5.7.0.9.

Comment 10 Tzu-Mainn Chen 2016-11-07 16:58:01 UTC
Andy, is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1381862 now?

Comment 11 Andrey 2016-11-21 14:52:42 UTC
Tzu-Mainn, yes, it looks the same to me

Comment 12 Tzu-Mainn Chen 2016-11-21 15:23:03 UTC

*** This bug has been marked as a duplicate of bug 1381862 ***


Note You need to log in before you can comment on or make changes to this bug.